View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001222aMuleMessagespublic2007-12-15 14:472008-01-06 17:27
Reportersasquate 
Assigned ToXaignar 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.1.3 
Target VersionFixed in Version 
Summary0001222: Problem trying download list of servers
DescriptionWhen i try to download the list of servers i receive this massage of error, and the program shut down.
Additional Informationmarcosandrade@marcosandrade-desktop:~/Programas/azureus$ amule
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
Loading temp files from /home/marcosandrade/.aMule/Temp.

All PartFiles Loaded.
ListenSocket: Ok.

External connections disabled in config file
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Empty dir /home/marcosandrade/.aMule/Incoming/ shared
HTTP download thread started

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67 [^]
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces [^]

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.1.3 using wxGTK2 v2.8.1 (Unicoded)
Running on: Linux 2.6.20-15-generic i686

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x8084c8b]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xb7540206]
[4] ?? in [0xffffe420]
[5] wxGIFDecoder::ConvertToImage(unsigned int, wxImage*) const in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb77f62af]
[6] wxTextCtrl::wxTextCtrl() in amule [0x823906d]
[7] wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const in /usr/lib/libwx_baseu-2.8.so.0[0xb7493d65]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xb753bcbf]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0xb753be0d]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xb753bf76]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb7841fe1]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0xb771d555]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0xb6ef13c6]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb6ef0df2]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0xb6ef3dcf]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb6ef4179]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb6ca2044]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb7713d0c]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb77b5cee]
[20] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb77b52e1]
[21] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb74d027a]
[22] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb74d0327]
[23] CryptoPP::IteratedHash<unsigned int, CryptoPP::EnumToType<CryptoPP::ByteOrder, 0>, 64u, CryptoPP::HashTransformation>::~IteratedHash() in amule [0x812f490]
[24] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xb71feebc]
[25] wxNotebook::SetPadding(wxSize const&) in amule[0x8080fd1]


--------------------------------------------------------------------------------
Cancelado (core dumped)
marcosandrade@marcosandrade-desktop:~/Programas/azureus$
TagsNo tags attached.
Fixed in Revision
Operating SystemUbuntu
Attached Files

- Relationships

-  Notes
(0002474)
rperodin (reporter)
2007-12-15 15:09

I have the exact same problem with Kubuntu 7.04
(0002494)
Xaignar (manager)
2008-01-06 17:27

Thanks for reporting the problem. This issue has been fixed in current SVN, so you might consider upgrading to a SVN build until the next release. You can find packages here: http://forum.amule.org/index.php?board=70.0 [^] [^]

If that is not an option, then you edit ~/.aMule/amule.conf and ensure that the following keys are set to 0, rather than 1:
 - NewVersionCheck
 - IPFilterAutoLoad
 - Serverlist

Also avoid using the built-in download functionality.

- Issue History
Date Modified Username Field Change
2007-12-15 14:47 sasquate New Issue
2007-12-15 14:47 sasquate Operating System => Ubuntu
2007-12-15 15:09 rperodin Note Added: 0002474
2008-01-06 17:27 Xaignar Status new => resolved
2008-01-06 17:27 Xaignar Resolution open => fixed
2008-01-06 17:27 Xaignar Assigned To => Xaignar
2008-01-06 17:27 Xaignar Note Added: 0002494


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker