View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001368aMuleExternal Connpublic2008-08-05 20:222009-03-23 13:46
Reporterkubrick 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in Version 
Summary0001368: Kad firewalled
DescriptionIn 2.2.2rc2, Kademlia remains "firewalled" whatever you do while it was working in 2.2.1.
TagsNo tags attached.
Fixed in Revision
Operating SystemwxMac 2.8.8 on Mac OS 10.5
Attached Files

- Relationships

-  Notes
(0002913)
kubrick (reporter)
2008-08-13 23:26

The problem is still here in 2.2.2.

I used tcpdump to check what's going on after bootstraping from known clients or downloading a fresh list from http://emule-inside.net/nodes.dat [^] :
There are hundreds of packets sent but only a few (1 or 2%) replies.
I sent some packets to my ports from outside my home network to check if my ports were properly forwarded : they are.

In that "firewalled state" aMule doesn't find any source or file.
(0002953)
Kry (manager)
2008-09-17 15:20

Works for me. I would review the firewall in mac, remember it digitally signs the applications and when you change it (i.e. if you overwrite it with a new version) and the signature is not updated, the firewall rules won't apply.
(0002988)
kubrick (reporter)
2008-11-07 14:26

The firewall on my Mac is completely disabled and, as I told you, I checked if the ports were properly forwarded.

I also tried with the gtoso's build on the forum it doesn't work.
I tried it on my two Macs (10.4 & 10.5) and it doesn't work too.
(0002989)
kubrick (reporter)
2008-11-07 14:30

I downgraded to 2.2.1 and now it works. So I'm sure there's a problem with 2.2.2.
(0002990)
Wuischke (manager)
2008-11-07 19:57

Please review your firewall settings again, delete any existing aMule rules and create a new one. (Please do so, even if your firewall is disabled.)

There's nothing we can do about this, this is most probably a local configuration issue.
(0003036)
kubrick (reporter)
2009-01-06 23:13

Hello,

Trust me it is the last time I re-open this bug.

I still have the problem with 2.2.3. Please let me make some things clear :
_I have NEVER activated the firewall on my Macs.
_Tiger does NOT have an application-signature-based firewall
_aMule 2.2.2 & 2.2.3 don't work (kad firewalled) on both my Leopard and Tiger Macs
_aMule 2.2.1 works very well on the same machines with the same network configuration (I tried downgrading).

Given these informations :
_How could it be "a local configuration issue"?
_Please tell me which informations you need in order to track that bug.

I know I'm annoying. And I know I could be wrong, but I'm pretty sure there's a bug...

Thanks.
Kub.
(0003042)
kubrick (reporter)
2009-01-08 08:49

Got this in my logs

[...]
2009-01-08 08:46:04: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 3244677576:4672: 35b
2009-01-08 08:46:04: MuleUDPSocket.cpp(233): MuleUDPSocket: Client UDP-Socket: Packet queued: 80.59.96.245:13267 33b
2009-01-08 08:46:04: Search.cpp(1110): Client Kademlia UDP: KadReq(Node) to 80.59.96.245:13267
2009-01-08 08:46:05: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 4116724560:13267: 35b
2009-01-08 08:46:05: MuleUDPSocket.cpp(233): MuleUDPSocket: Client UDP-Socket: Packet queued: 85.136.84.9:4672 33b
2009-01-08 08:46:05: Search.cpp(1110): Client Kademlia UDP: KadReq(Node) to 85.136.84.9:4672
2009-01-08 08:46:05: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 156534869:4672: 35b
2009-01-08 08:46:06: MuleUDPSocket.cpp(233): MuleUDPSocket: Client UDP-Socket: Packet queued: 80.82.32.37:6346 33b
2009-01-08 08:46:06: Search.cpp(1110): Client Kademlia UDP: KadReq(Node) to 80.82.32.37:6346
2009-01-08 08:46:07: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 622875216:6346: 35b
2009-01-08 08:46:07: MuleUDPSocket.cpp(233): MuleUDPSocket: Client UDP-Socket: Packet queued: 67.160.89.72:4672 33b
2009-01-08 08:46:07: Search.cpp(1110): Client Kademlia UDP: KadReq(Node) to 67.160.89.72:4672
2009-01-08 08:46:08: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 1213833283:4672: 35b
2009-01-08 08:46:08: MuleUDPSocket.cpp(233): MuleUDPSocket: Client UDP-Socket: Packet queued: 62.219.134.233:63227 33b
2009-01-08 08:46:08: Search.cpp(1110): Client Kademlia UDP: KadReq(Node) to 62.219.134.233:63227
2009-01-08 08:46:09: MuleUDPSocket.cpp(341): MuleUDPSocket: Client UDP-Socket: Packet sent to 3917929278:63227: 35b
2009-01-08 08:46:11: Prefs.cpp(272): Kademlia Preferences: Counted Kad V8 Contacts: 0 out of 90 in routing table. FirewalledRatios: UDP - 0,00% | TCP - 0,00%
2009-01-08 08:46:12: Kademlia.cpp(210): Kademlia Main Thread: No valid client for requesting external port available


And I can't search anything nor find any source...
(0003056)
Wuischke (manager)
2009-01-17 22:14

I can't solve your problem, but the error message (last line in your log) is because you have no Kad contacts and therefore no client could be "pinged". (This will be tried every 15 seconds).

Btw: Did you try loading a new nodes.dat?

Well, the only thing which comes in my mind would be to diff 2.2.1 and 2.2.2 and see if there were any changes related to Kademlia or UDP sockets - would you be so kind as to give me a clue about possible sources of this error?
(0003064)
kubrick (reporter)
2009-01-18 22:43
edited on: 2009-01-18 22:44

Hi,

I still have no real clue of where the problem comes from but I noticed a strange thing that MAY be related.
My local IP is 192.168.0.200. If, via the preferences, I try to bind specifically to that IP (and not 0.0.0.0), an error message is displayed saying that aMule where not able to bind to that address and port (TCP). Which is strange because netstat shows that nothing listen on that IP & port, and I can listen on that IP/port with socat without any problem...
I added some traces in the code and I found that aMule seems to do things correctly but wx says it couldn't bind... Strange.
As I have some skills in programming (it's my job after all...) and no one else seems to reproduce the problem, I'll try to spend some time on it.

To answer your question Wuischke, as stated in my first message I did try to load a fresh nodes.dat.

I'll keep you up-to-date on what I'll (not) find.

modifié le : 01-18-09 22:44
(0003065)
Wuischke (manager)
2009-01-21 19:30

I'm very glad you decided to have a look at this problem. Thank you.

It's very hard to solve a problem you cannot reproduce - or as you have seen, even to recognize it as a problem and not merely a common issue with similar symptoms.

- Issue History
Date Modified Username Field Change
2008-08-05 20:22 kubrick New Issue
2008-08-05 20:22 kubrick Operating System => wxMac 2.8.8 on Mac OS 10.5
2008-08-13 23:26 kubrick Note Added: 0002913
2008-09-17 15:20 Kry Note Added: 0002953
2008-09-19 16:59 Wuischke Status new => resolved
2008-09-19 16:59 Wuischke Resolution open => no change required
2008-09-19 16:59 Wuischke Assigned To => Wuischke
2008-11-07 14:26 kubrick Status resolved => feedback
2008-11-07 14:26 kubrick Resolution no change required => reopened
2008-11-07 14:26 kubrick Note Added: 0002988
2008-11-07 14:30 kubrick Note Added: 0002989
2008-11-07 19:57 Wuischke Status feedback => resolved
2008-11-07 19:57 Wuischke Resolution reopened => unable to reproduce
2008-11-07 19:57 Wuischke Note Added: 0002990
2009-01-06 23:13 kubrick Status resolved => feedback
2009-01-06 23:13 kubrick Resolution unable to reproduce => reopened
2009-01-06 23:13 kubrick Note Added: 0003036
2009-01-08 08:49 kubrick Note Added: 0003042
2009-01-17 22:14 Wuischke Note Added: 0003056
2009-01-18 22:43 kubrick Note Added: 0003064
2009-01-18 22:44 kubrick Note Edited: 0003064
2009-01-21 19:30 Wuischke Note Added: 0003065
2009-03-23 13:46 Wuischke Assigned To Wuischke =>


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker