View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001537aMuleUtilitiespublic2009-06-28 16:052009-07-11 22:13
ReporterAceX5 
Assigned Tosturedman 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformLinuxOSGentoo LinuxOS Version2.6.29-r5
Product VersionSVN 
Target VersionFixed in Version 
Summary0001537: net-p2p/amule-2.2.5: amulecmd always shows 000.part.met
DescriptionThe amulecmd command does not correctly display the *.part.met information in
the show dl and show ul output. It will display 000.part.met for all downloads.

$ amulecmd
This is amulecmd 2.2.5

Creating client...
Succeeded! Connection established to aMule 2.2.5

---------------------------------------
| aMule text client |
---------------------------------------

Use 'Help' for command list

aMulecmd$ show dl
 > 00000000000000000000000000000000 File_A.download
 > [1.3%] 0/ 0 - Waiting - 000.part.met - Auto [Hi]
 > 00000000000000000000000000000000 File_B.download
 > [0.0%] 0/ 0 - Waiting - 000.part.met - Auto [Hi]
Steps To Reproduce1. Add new download via WebUI
2. invoke amulecmd
3. issue show dl to check *.part.met file name

Actual Results:
will always display 000.part.met

Expected Results:
should return the correct temporary file name of the running download
Additional InformationThis feature has been introduced in aMule Bug 0000870. Gentoo Bugzilla Bug 272101 reports this issue.
TagsNo tags attached.
Fixed in Revision
Operating SystemLinux
Attached Files

- Relationships

-  Notes
(0003204)
sturedman (developer)
2009-06-29 23:38

Please retry with aMule / amulecmd from current SVN. It works for me with it.
(0003218)
AceX5 (reporter)
2009-07-02 21:30

Can't confirm that. Still the same with SVN trunk 9692...

acex5@plex ~ $ amulecmd --version
amulecmd SVN using v2.8.9 (Snapshot: rev. 9692)
acex5@plex ~ $ amulecmd -c "show dl"
This is amulecmd SVN rev. 9692

Creating client...
Succeeded! Connection established to aMule SVN
 > 00000000000000000000000000000000 download_name
 > [0.1%] 0/ 0 - Waiting - 000.part.met - Auto [Hi]
 > 00000000000000000000000000000000 download_name
 > [11.3%] 0/ 0 - Waiting - 000.part.met - Auto [Hi]
(0003219)
sturedman (developer)
2009-07-04 14:09

Are you using amule or amuled? Is it from SVN too?
(0003220)
AceX5 (reporter)
2009-07-05 22:31
edited on: 2009-07-09 18:25

I'm using amuled. Got the SVN tarball (9692) from http://amule.sourceforge.net/tarballs [^] . Should I try another version?

edited on: 07-09-09 18:25
(0003225)
sturedman (developer)
2009-07-11 22:13

You have a big endian machine, right ?
Should be fixed with 9701, please verify it.

- Issue History
Date Modified Username Field Change
2009-06-28 16:05 AceX5 New Issue
2009-06-28 16:05 AceX5 Operating System => Linux
2009-06-29 23:38 sturedman Note Added: 0003204
2009-06-29 23:38 sturedman Assigned To => sturedman
2009-06-29 23:38 sturedman Status new => feedback
2009-06-29 23:38 sturedman Description Updated
2009-06-29 23:38 sturedman Steps to Reproduce Updated
2009-07-02 21:30 AceX5 Note Added: 0003218
2009-07-04 14:09 sturedman Note Added: 0003219
2009-07-05 22:31 AceX5 Note Added: 0003220
2009-07-09 18:25 AceX5 Note Edited: 0003220
2009-07-11 22:13 sturedman Note Added: 0003225
2009-07-11 22:13 sturedman Status feedback => resolved
2009-07-11 22:13 sturedman Resolution open => fixed
2009-07-11 22:13 sturedman Product Version 2.2.5 => SVN
2009-07-11 22:13 sturedman Description Updated
2009-07-11 22:13 sturedman Steps to Reproduce Updated


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker