View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001713aMuleGUIpublic2012-03-23 11:292016-04-18 11:54
Reporteruleysky 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version2.3.1 
Target VersionFixed in Version 
Summary0001713: AMule don't recognize ed2k links with russian file names
DescriptionIf I try to add a ed2k link with russian file name (such as ed2k://|file|????|512|55B681575E8F49CA67CBAB34543EC7E6|/ [^]), aMule only write "Not a valid ed2k-URI" in log. The same problem with chinese symbols. But search of files with russian names work fine and such files downloaded without any problem. Only manual link addition don't work.
TagsNo tags attached.
Fixed in Revision
Operating SystemLinux
Attached Files

- Relationships

-  Notes
(0003686)
Marcell (developer)
2016-04-09 18:58

This is working fine for me with the URI ed2k://|file|????|512|55B681575E8F49CA67CBAB34543EC7E6|/. [^] Perhaphs it is related to some locale setting. What does the command "locale" say on your side?
(0003689)
uleysky (reporter)
2016-04-18 11:52
edited on: 2016-04-18 11:54

The bugzilla eat russian letters and replaces by ?.
I put another link on pastebin http://pastebin.com/p39dQmNS [^]

Locale is following
LANG=ru_RU.UTF8
LC_CTYPE="ru_RU.UTF8"
LC_NUMERIC="ru_RU.UTF8"
LC_TIME="ru_RU.UTF8"
LC_COLLATE="ru_RU.UTF8"
LC_MONETARY="ru_RU.UTF8"
LC_MESSAGES="ru_RU.UTF8"
LC_PAPER="ru_RU.UTF8"
LC_NAME="ru_RU.UTF8"
LC_ADDRESS="ru_RU.UTF8"
LC_TELEPHONE="ru_RU.UTF8"
LC_MEASUREMENT="ru_RU.UTF8"
LC_IDENTIFICATION="ru_RU.UTF8"
LC_ALL=


- Issue History
Date Modified Username Field Change
2012-03-23 11:29 uleysky New Issue
2012-03-23 11:29 uleysky Operating System => Linux
2016-04-09 18:58 Marcell Note Added: 0003686
2016-04-18 11:52 uleysky Note Added: 0003689
2016-04-18 11:54 uleysky Note Edited: 0003689 View Revisions


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker