aMule Bug Tracker - aMule
View Issue Details
0001497aMulePreferencespublic2009-02-25 14:192011-04-17 14:48
resolvedno change required 
Mac OS X 10.5.6 FR
0001497: ipfilter failed to load

Each time I start aMule, I get the error in the aMule log:
"Échec du chargement de fichier ipfilter.dat '/Users/pre/Library/Application Support/aMule/ipfilter.dat', format inconnu."
That mean: failed to load ipfilter.dat, because the file is in an unknow format.
I tried lot of different ipfilter.dat and I get each time the same error.
I have tried to use .dat and .zip format in the URL to load the file, but I get the same error.
I'm using aMule 2.2.3 on Mac OS X 10.5.6 French.
Could you check if the ipfilter feature works well ?

No tags attached.
Issue History
2009-02-25 14:19PReNew Issue
2009-02-25 14:19PReOperating System => Mac OS X 10.5.6 FR
2009-02-28 00:03sturedmanNote Added: 0003086
2009-04-06 01:19PReNote Added: 0003111
2009-05-12 17:47MarcellNote Added: 0003132
2011-04-17 14:48GonoszTopiStatusnew => resolved
2011-04-17 14:48GonoszTopiResolutionopen => no change required

2009-02-28 00:03   
Try removing the comments frome the filter file, especially the >> characters.
2009-04-06 01:19   

I apologize for delay in answering.
I have followed your advice, and that successfuly fix the problem.

Maybe you should consider review ipfilter parsing in amule, in order to avoid the need of manual removing of comments line.

Many thanks for help.
2009-05-12 17:47   
Which file contains the ">>" characters?

I had a look into ipfilter.dat and ipfilter_static.dat and there is no such thing.