aMule Bug Tracker - aMule
View Issue Details
0001622aMuleExternal Connpublic2010-09-02 21:092010-09-04 02:24
normalcrashhave not tried
closedno change required 
0001622: aMule crashes on startup with Gdk-ERROR: 'BadMatch (invalid parameter attributes)'
Binary package hint: amule

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
Description: Ubuntu maverick (development branch)
Release: 10.10

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
  Installed: 2.2.6+debian0-7
  Candidate: 2.2.6+debian0-7

3) What you expected to happen
The program starts and runs normally.

4) What happened instead
jimmy@jimmy:~$ amule
Initialising aMule 2.2.6 using wxGTK2 v2.8.10
Checking if there is an instance already running...
No other instances are running.
ListenSocket: Ok.
HTTP download thread started

Gdk-ERROR **: The program 'amule' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 2825 error_code 8 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap
Original bug report at ubuntu's launchpad: [^]

In the first comment of the report, a possible solution is suggested:
    "export XLIB_SKIP_ARGB_VISUALS=1 works."
No tags attached.
Issue History
2010-09-02 21:09user3022New Issue
2010-09-02 21:09user3022Operating System => linux
2010-09-04 02:24sturedmanNote Added: 0003485
2010-09-04 02:24sturedmanStatusnew => closed
2010-09-04 02:24sturedmanResolutionopen => no change required

2010-09-04 02:24   
This is not a bug of aMule. aMule runs fine in Maverick alpha.
But you can't just install an old binary package in a new distro and expect it to run.
It's the job of the Debian/Ubuntu packager to provide a new binary package compiled/linked with Maverick. (Maverick comes with wxGTK 2.8.11, this alone tells me you tried an old package.)