aMule Bug Tracker - aMule
View Issue Details
0001645aMuleExternal Connpublic2011-01-02 14:252011-01-14 11:50
0001645: Same problem with issue 0001606: stops responding when network down
I have facing the same problem of issue 0001606. I am using a wireless network which is not very stable. In this situation, aMule almost stops responding when the wireless network going bad.

I am also using ubuntu 10.04, which uses amule 2.2.6. To trace this problem, I have already downloaded the 2.2.6 source code from your website and prepared the environment for debugging.

In the version compiled from source code, I opened amule and let it download several files, and then unplugged the usb wireless adapter. In the first trial of the procedure above, amule stopped (almost) the system from responding and the hard disk activity indicator keep lighting. When I tried to close amule it shows an Exit dialog without controls. However, when I just type enter it stops properly.

However, the another trial is ok. This suggests the bug is not always occur but if the network is not stable you have a chance to catch it.

I feel that the lighting hard disk indicator may suggest something is wrong in the file I/O subsystem.

If more detail is needed I would like to do more tests for you, and if you ask me to test some change of code I can also help.
This problem is not only occur in Ubuntu, ant not only in the current version. I believe it is an old issue at least in a 3 year old version on other Linux systems.
No tags attached.
Issue History
2011-01-02 14:25earthengineNew Issue
2011-01-02 14:25earthengineOperating System => Linux
2011-01-08 20:51sturedmanNote Added: 0003519
2011-01-14 11:50earthengineNote Added: 0003530

2011-01-08 20:51   
Can you try if the problem persists in current SVN?
2011-01-14 11:50   
Hi sturedman, I have tried the git version with aMule title "aMule SVN rev. 10424", and it still the same. As what I observed before, it is not easy to reproduce.

What I am going to do now, is to add a new shortcut key that causes aMule to exit immediately, without confirmation.

According to what I have observed, my first feeling is it looks like a virtual memory overload. That means for some reason aMule suddenly allocated a lot of memory. But I cannot test this because when the system going crazy it is hard to run a memory monitor. I might be able to find some software to do that.