View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001141aMuleMiscpublic2007-07-13 01:532007-07-13 12:19
Reporterarnoschaefer 
Assigned ToWuischke 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.1.3 
Target VersionFixed in Version 
Summary0001141: wxGTK 2.6 bug/amule does not compile with wxGTK 2.8
DescriptionPeople keep recommending wxGTK 2.8.* when encountering the crash bug with wxGTK 2.6 when closing all tabs. However amule 2.1.3 does not compile with wxGTK 2.8.*:

MuleGifCtrl.cpp:132: error: class wxGIFDecoder has no member named GetLogicalScreenWidth

the GetLogicalScreenWidth method was apparently eliminated from wxGTK in version 2.8, but aMule still uses it. Is there a version adapted to wxGTK 2.8?
TagsNo tags attached.
Fixed in Revision
Operating SystemAny
Attached Files

- Relationships

-  Notes
(0002356)
Wuischke (manager)
2007-07-13 12:19

Patch for 2.1.3: http://forum.amule.org/index.php?topic=11834.0 [^]

However, it is recommended to use aMule CVS tarball (amule.hirnriss.net) as they run stable and there will be only few changes until the release of aMule 2.2.0

- Issue History
Date Modified Username Field Change
2007-07-13 01:53 arnoschaefer New Issue
2007-07-13 01:53 arnoschaefer Operating System => Any
2007-07-13 12:19 Wuischke Status new => resolved
2007-07-13 12:19 Wuischke Resolution open => fixed
2007-07-13 12:19 Wuischke Assigned To => Wuischke
2007-07-13 12:19 Wuischke Note Added: 0002356


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker