View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001163aMuleUtilitiespublic2007-08-27 20:012008-02-21 22:17
Reporterwondra 
Assigned ToKry 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.1.3 
Target VersionFixed in Version 
Summary0001163: aMule crashes on CPUs below Pentium - cryptopp error
DescriptionCryptopp (any, including included) unconditionally executes the cpuid instruction, resulting in "SIGILL - Illegal Instruction" on 486.
Additional InformationChanging the body of isPentium() to return false; fixes the problem. Could it be disabled automatically at compile time? Have the Cryptopp guys fixed it already?
TagsNo tags attached.
Fixed in Revision
Operating SystemLinux 2.4.25
Attached Files

- Relationships

-  Notes
(0002628)
Xaignar (manager)
2008-02-21 22:17

I believe that this has been fixed in more recent Crypto++ versions. If not, then we'll need to bug-rep them, as aMule no longer includes its own copy of the crypto++ libraries.

- Issue History
Date Modified Username Field Change
2007-08-27 20:01 wondra New Issue
2007-08-27 20:01 wondra Operating System => Linux 2.4.25
2007-08-28 20:37 Kry Status new => assigned
2007-08-28 20:37 Kry Assigned To => Kry
2008-02-21 22:17 Xaignar Status assigned => resolved
2008-02-21 22:17 Xaignar Resolution open => fixed
2008-02-21 22:17 Xaignar Note Added: 0002628


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker