View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001423aMuleMulti Platformpublic2008-10-09 21:542016-04-17 03:54
Reporteryelo3 
Assigned ToGonoszTopi 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.2.2 
Target VersionFixed in Version2.3.2 
Summary0001423: Add the possibility to not create sparse files
DescriptionIn a multi OS environment, where temp files are shared between more OSs it is a good idea to not use sparse files, so that OSs that are not as good as linux to use them are not penalized with crashes.
The only thing I request is to add an option to disable the creation of sparse files.
TagsNo tags attached.
Fixed in Revision10919
Operating SystemAny
Attached Files

- Relationships

-  Notes
(0002977)
pcordes (reporter)
2008-10-26 05:05

There's already a pref setting (in Files): Preallocate disk space for new files. That should do the trick, although it will use the full disk space right away, so it's different from writing zeros out to where you're going to put a block. It should solve your problem, though.

 BTW, what OS can read a filesystem that supports sparse files, but not handle sparse files properly on it? Is this a common-enough case to bother doing anything more than suggesting using the pre-allocate option?
(0003100)
yelo3 (reporter)
2009-03-17 20:07

Sorry for not having answered for long time, the OS we're talking about is Vista.
I've done a research with the ntfs-3g maintainer, and he discovered that even emule switched off sparse files support in vista, maybe because of this problem
(0003196)
yelo3 (reporter)
2009-06-28 14:37

So, you could enable by default the pre-allocation on ntfs partitions.

BTW: I don't receive email when new notes are added or the bug changes status. I don't know why, this might be a bug the bug tracker.

- Issue History
Date Modified Username Field Change
2008-10-09 21:54 yelo3 New Issue
2008-10-09 21:54 yelo3 Operating System => Any
2008-10-26 05:05 pcordes Note Added: 0002977
2008-11-01 17:41 GonoszTopi Status new => resolved
2008-11-01 17:41 GonoszTopi Resolution open => no change required
2008-11-01 17:41 GonoszTopi Assigned To => GonoszTopi
2009-03-17 20:07 yelo3 Status resolved => feedback
2009-03-17 20:07 yelo3 Resolution no change required => reopened
2009-03-17 20:07 yelo3 Note Added: 0003100
2009-04-05 12:23 GonoszTopi Status feedback => acknowledged
2009-04-05 12:23 GonoszTopi Description Updated
2009-06-28 14:37 yelo3 Note Added: 0003196
2009-06-28 14:43 yelo3 Note Added: 0003197
2009-06-28 14:51 yelo3 Note Deleted: 0003197
2016-04-17 03:54 GonoszTopi Fixed in Revision => 10919
2016-04-17 03:54 GonoszTopi Status acknowledged => resolved
2016-04-17 03:54 GonoszTopi Resolution reopened => fixed
2016-04-17 03:54 GonoszTopi Fixed in Version => 2.3.2


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker