View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001585aMuleExternal Connpublic2010-02-01 14:082016-05-06 22:30
Reportermarcelpb 
Assigned ToGonoszTopi 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version2.2.6 
Target Version2.3.1Fixed in Version 
Summary0001585: Problem with Max TCP Connections [Solved]
DescriptionWhen you are running amuled and your settings for max connections are very high (MaxConnections = 1000), amuled crashes. I'm developer (in C++ in fact) and I guess I've solved the problem. The main problem here is the use of 'select' instead of 'poll'. 'Select' only works for a maximum of 1024 connections, but 'poll' have the system maximum connections.

I've attached the modified files for your review. I'm testing the changes and it seems that works fine.

If you have any question, please send me a mail.

Regards.
Additional InformationChanges
-------
- In 'amule.h'
  * Row 387 -> 'm_set' instead of 'm_in_set' and 'm_out_set'.
- In 'amuled.cpp'
  * Class CSocketSet
  * Functions in class CAmuledGSocketFuncTable:
    + CAmuledGSocketFuncTable()
    + AddSocket
    + RemoveSocket
    + RunSelect

No more changes are needed in the original sources.
TagsNo tags attached.
Fixed in Revision10582
Operating SystemLinux
Attached Filestgz file icon changes_poll.tgz [^] (9,789 bytes) 2010-02-01 14:08
txt file icon amule backtrace.txt [^] (14,262 bytes) 2011-07-06 23:55 [Show Content]

- Relationships

-  Notes
(0003377)
marcelpb (reporter)
2010-02-01 14:59

Sorry, I'm new and I don't know if this is the best category (maybe Servers is better, I don't know).
(0003378)
sturedman (developer)
2010-02-01 21:07

Please make patches based on current SVN and not on 2.2 .
Also notice that the issue is already solved when using wxWidgets 2.9, so I'm not sure it's still worth digging in this place.
(0003382)
marcelpb (reporter)
2010-02-02 00:43

I guess you are wrong. This problem is not in wxWidget, is in amuled source. It's because the use of 'select'. This function only can work with a maximum of 1024 connections, and it cames with kernel, no in wxWidgets. My solution proposes the use of 'poll' insted, and can be applied to the SVN source code (I've downloaded this version, and it is exactly the same than 2.2 version).
(0003383)
sturedman (developer)
2010-02-02 22:10

Don't guess, look at the source.
And what do you mean, SVN source is the same as 2.2 ?
(0003583)
sturedman (developer)
2011-06-22 12:38

This is causing problems.

http://forum.amule.org/index.php?topic=18982.0 [^]

(And why do I have to "request feedback" and can't simply reset it to open?)
(0003585)
miguelssm (reporter)
2011-07-06 23:57

I've tried this solution but it doesn't work with me.
You can see the backtrace in the attached file.
amule_backtrace.txt
Thanks in advance.

MiguelSSM
(0003588)
sturedman (developer)
2011-07-07 22:45

This "fix" is broken, so don't try it.
(0003589)
miguelssm (reporter)
2011-07-07 23:49

So, what can I do?
I'm not sure if this bugs is related to mine:

http://bugs.amule.org/view.php?id=1678 [^]

Do you recommend me to compile 2.2.6 or SVN?
Is this bug fixed in SVN version?
(0003590)
sturedman (developer)
2011-07-08 21:19

At the moment you can
a) use less connections in amuled (2.2.6 or SVN < 10582)
b) use amuled SVN with wxWidgets 2.9 SVN
As I said, the fix is broken, and so are currently all SVN version >= 10582 (unless compiled with wx 2.9).

- Issue History
Date Modified Username Field Change
2010-02-01 14:08 marcelpb New Issue
2010-02-01 14:08 marcelpb File Added: changes_poll.tgz
2010-02-01 14:08 marcelpb Operating System => Linux
2010-02-01 14:59 marcelpb Note Added: 0003377
2010-02-01 14:59 marcelpb Tag Attached: amuled
2010-02-01 14:59 marcelpb Tag Attached: connection
2010-02-01 14:59 marcelpb Tag Attached: max
2010-02-01 14:59 marcelpb Tag Attached: tcp
2010-02-01 21:07 sturedman Note Added: 0003378
2010-02-02 00:43 marcelpb Note Added: 0003382
2010-02-02 22:10 sturedman Note Added: 0003383
2010-02-03 17:45 GonoszTopi Tag Detached: tcp
2010-02-03 17:45 GonoszTopi Tag Detached: amuled
2010-02-03 17:45 GonoszTopi Tag Detached: connection
2010-02-03 17:45 GonoszTopi Tag Detached: max
2010-05-16 17:22 GonoszTopi Status new => assigned
2010-05-16 17:22 GonoszTopi Assigned To => GonoszTopi
2011-06-13 08:46 GonoszTopi Target Version => 2.3.1
2011-06-15 20:51 GonoszTopi Fixed in Revision => 10582
2011-06-15 20:51 GonoszTopi Status assigned => resolved
2011-06-15 20:51 GonoszTopi Resolution open => fixed
2011-06-15 20:51 GonoszTopi Fixed in Version => 2.3.1
2011-06-22 12:38 sturedman Note Added: 0003583
2011-06-22 12:38 sturedman Status resolved => feedback
2011-06-22 12:38 sturedman Resolution fixed => reopened
2011-07-06 23:55 miguelssm File Added: amule backtrace.txt
2011-07-06 23:57 miguelssm Note Added: 0003585
2011-07-07 22:45 sturedman Note Added: 0003588
2011-07-07 23:49 miguelssm Note Added: 0003589
2011-07-08 21:19 sturedman Note Added: 0003590
2016-05-06 22:30 GonoszTopi Status feedback => closed
2016-05-06 22:30 GonoszTopi Resolution reopened => won't fix
2016-05-06 22:30 GonoszTopi Fixed in Version 2.3.1 =>


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker