View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001613aMuleExternal Connpublic2010-07-30 11:482011-04-17 14:09
Reportermorph 
Assigned Tosturedman 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.2.6 
Target Version2.3.1Fixed in Version2.3.1 
Summary0001613: amulecmd search doesn't work
DescriptionHello,
I've started from this Debian bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=442130 [^] .

it's quite old, indeed, but I still can see it:

$ amulecmd
This is amulecmd 2.2.6
Enter password for mule connection:

Creating client...
Succeeded! Connection established to aMule 2.2.6

---------------------------------------
| aMule text client |
---------------------------------------

Use 'Help' for command list

aMulecmd$ search global debian
 > Request failed with the following error: Search in progress. Refetch results in a moment!
aMulecmd$ search kad debian
 > Request failed with the following error: Search in progress. Refetch results in a moment!
aMulecmd$

Regards,
Sandro
TagsNo tags attached.
Fixed in Revision10264
Operating SystemAny
Attached Files

- Relationships

-  Notes
(0003474)
sturedman (developer)
2010-08-08 17:41

Well, it says "Search in progress. Refetch results in a moment!".
That's what you have to do. Wait a bit, then type

aMulecmd$ results
(0003477)
morph (reporter)
2010-08-08 17:53

Ah ok, now I see it.

Anyhow I have a suggestion to make: please remove the "Request failed with the following error: " string, because it confuses the users (after all it didn't failed) and maybe add something like "wait a bit and then issue the 'results' command" after "Search in progress. Refetch results in a moment!" would be nice.

Just to recap, from:

  Request failed with the following error: Search in progress. Refetch results in a moment!

to:

  Search in progress. Please wait a bit and then issue the 'results' command to fetch search results

Do you think it's acceptable?

Thanks for considering,
Sandro
(0003478)
sturedman (developer)
2010-08-08 19:11

You are right of course...

Removed the "Request failed with the following error:" from the response. Now it is just:
"Search in progress. Refetch results in a moment!"

- Issue History
Date Modified Username Field Change
2010-07-30 11:48 morph New Issue
2010-07-30 11:48 morph Operating System => Any
2010-08-08 17:41 sturedman Note Added: 0003474
2010-08-08 17:41 sturedman Status new => closed
2010-08-08 17:41 sturedman Resolution open => no change required
2010-08-08 17:53 morph Note Added: 0003477
2010-08-08 17:53 morph Status closed => feedback
2010-08-08 17:53 morph Resolution no change required => reopened
2010-08-08 19:11 sturedman Fixed in Revision => 10264
2010-08-08 19:11 sturedman Note Added: 0003478
2010-08-08 19:11 sturedman Status feedback => resolved
2010-08-08 19:11 sturedman Resolution reopened => fixed
2010-08-08 19:11 sturedman Fixed in Version => 2.3.1
2010-08-08 19:11 sturedman Target Version => 2.3.1
2011-04-17 14:09 GonoszTopi Assigned To => sturedman


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker