View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000297aMuleMiscpublic2005-02-16 20:122005-02-25 15:24
Reportermherbert 
Assigned Tophoenix 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.0.0-rc8 
Target VersionFixed in VersionSVN 
Summary0000297: mplayer needs stdout
Descriptionthis is about the "preview" feature. It simply does not work for movies in my configuration: mplayer pops up and crashes immediately.

The workaround is to replace /usr/bin/mplayer by a shell script wrapper that does: 1>/tmp/anything mplayer "$@"

I dont know about the best fix, but it may imply giving a proper file descriptor number 1 before forking mplayer.

Actually a way to configure previewers would be even better.
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0000638)
mherbert (reporter)
2005-02-16 20:29

some tracing in the wrapper gives this information :

file /dev/stdout
 --> /proc/self/fd/1: broken symbolic link to `pipe:[287510]'
(0000642)
mherbert (reporter)
2005-02-16 20:59

Delete the node about broken symbolic link (debugging stdout can be confusing!).
Here is a mplayer wrapper that workarounds great for me:

#!/bin/sh
# let's try to dup fd 1 just to see. Hopefully fd 9 is not used already.
if exec 9>&1
then :
else exec 1>/tmp/mplayer_amule.log
fi
/usr/bin/mplayer.real "$@"
(0000646)
phoenix (developer)
2005-02-17 03:01
edited on: 2005-02-17 03:01

Your script does not work for me, mplayer keeps getting strange chars and interpreting them as keyboard functions. Otoh, this script works for me (the file name is mplayer.sh, and the permissions are 0755):

#!/bin/bash
mplayer -vo xv "$@" >/dev/null </dev/null

edited on: 02-17-05 03:01

- Issue History
Date Modified Username Field Change
2005-02-16 20:12 mherbert New Issue
2005-02-16 20:29 mherbert Note Added: 0000638
2005-02-16 20:59 mherbert Note Added: 0000642
2005-02-17 03:01 phoenix Note Added: 0000646
2005-02-17 03:01 phoenix Note Edited: 0000646
2005-02-17 03:03 phoenix Status new => confirmed
2005-02-20 15:58 phoenix Status confirmed => closed
2005-02-25 15:24 phoenix Status closed => resolved
2005-02-25 15:24 phoenix Fixed in Version => CVS
2005-02-25 15:24 phoenix Resolution open => fixed
2005-02-25 15:24 phoenix Assigned To => phoenix


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker