View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000374aMuleMiscpublic2005-04-13 13:072005-05-02 17:52
Reporterm2kio 
Assigned ToKry 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in VersionSVN 
Summary0000374: misc. problems with friends
Descriptionin Friends:Username:context menu:
(1) no tag added to "Add friends slot" when friends slot is assigned. in some previous cvs the tag _was_ added, so i believe, it is no wxMac issue.
(2) frequently friends slot can't be assigned to a friend, even if i'm currently upping and downing with him, that is: menu item is dimmed. deleting friend, re-assigning friend state and then assigning friend slot worked, that is, menu item then was selectable.
Additional InformationwxMac 2.5.5
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0000890)
Kry (manager)
2005-04-22 04:16

This should be fixed. Check it.
(0000891)
Kry (manager)
2005-04-22 05:02

Done
(0000899)
m2kio (reporter)
2005-04-22 13:31

(1) now more than 1 friend can be tagged as "Establish friend slot". i don't know whether this is as at it actually works or wrong now. anyway i think it is good to allow any number of friends to share even only one slot in a time-sliced manner.

(2) assigning friends slot seems to have no effect. until now assigning a friends slot seemed to boost the score of that peer in the ul list. but now it doesn't. neither if only one friend is set for friends slot, neither high id or low id peer, neither if multiple friends are assigned a friends slot.

then after setting a single peer to friends slot, it was boosted for some secs, then it's score was lowered to normal. then for this and other peers "establish friend slot" in the "friends" list was dimmed and "show details" too. though peer was in ul waiting list and there "show details" worked.
(0000903)
Kry (manager)
2005-04-22 13:58

Uh... damm :)
(0000908)
Kry (manager)
2005-04-24 17:53

And now?
(0000936)
Kry (manager)
2005-04-28 02:01

No input, case closed.
(0000941)
m2kio (reporter)
2005-04-30 21:50

sorry for the time waiting, Kry.
issue partly still persists. see forum thread 5611 too.
now tagging one friend slot untags other. if any. OK
but friends slot assignment is still very wacky:
first friend gets high score in UL queue: OK
then it is successfully assigned next free slot OR
it flashes for a sec in the DL list, then disappears and reenters queue after some minutes. then "assign friend slot" is dimmed and "show details" from friends list doesnt work.
OR it seems to get suddenly canceled the friends slot state while waiting for the next slot to become free.
it seems to be especially impossible to assign a friends slot to a lowID peer.
again, sorry for waiting. m2kio !
this friends slot tingy seems to be a mess.
(0000943)
Kry (manager)
2005-05-02 04:40

It should be fixed NOW. I need confirmation ASAP.
(0000948)
Kry (manager)
2005-05-02 17:52

delta confirmed it's fixed.

- Issue History
Date Modified Username Field Change
2005-04-13 13:07 m2kio New Issue
2005-04-18 15:07 Kry Status new => assigned
2005-04-18 15:07 Kry Assigned To => Kry
2005-04-22 04:16 Kry Note Added: 0000890
2005-04-22 05:02 Kry Status assigned => resolved
2005-04-22 05:02 Kry Fixed in Version => CVS
2005-04-22 05:02 Kry Resolution open => fixed
2005-04-22 05:02 Kry Note Added: 0000891
2005-04-22 13:31 m2kio Status resolved => feedback
2005-04-22 13:31 m2kio Resolution fixed => reopened
2005-04-22 13:31 m2kio Note Added: 0000899
2005-04-22 13:58 Kry Note Added: 0000903
2005-04-24 17:53 Kry Note Added: 0000908
2005-04-28 02:01 Kry Status feedback => resolved
2005-04-28 02:01 Kry Resolution reopened => fixed
2005-04-28 02:01 Kry Note Added: 0000936
2005-04-30 21:50 m2kio Status resolved => feedback
2005-04-30 21:50 m2kio Resolution fixed => reopened
2005-04-30 21:50 m2kio Note Added: 0000941
2005-05-02 04:40 Kry Note Added: 0000943
2005-05-02 17:52 Kry Status feedback => closed
2005-05-02 17:52 Kry Note Added: 0000948


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker