View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000451aMuleMiscpublic2005-05-23 19:102005-12-09 23:48
Reporterphilippe landau 
Assigned ToKry 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.0.1 
Target VersionFixed in VersionSVN 
Summary0000451: memory leak
Descriptionafter a day of use, and when downloads start to work well, memory increases so much that the harddisks are paging without interruption. when i close aMule then, it takes about 10 minutes, during which virtual memory use by aMule increases from 300 MB to over 3 GB, until aMule quits without error. i have 500 MB RAM and 2 GB swap space, using Mandriva LE2005 PLF-aMule.

kind regards philippe
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships
related to 0000455closed Memory usage grows up indefinitely. 

-  Notes
(0001002)
Kry (manager)
2005-05-26 01:46

wx bug...
(0001145)
Xaignar (manager)
2005-07-15 14:14

As kry said, this is a problem with wxGTK. I'd recommend that you reinstall a copy of wxGTK using GTK1, since GTK2 is yet not completly ready for prime time in any version of wxGTK.
(0001278)
philippe landau (reporter)
2005-09-10 17:52

i am a user and have no way to change the wxGTK.
however, AndyRTR said he is ready to try to make a new package.
i hope you can guide him through it.
(0001446)
arichy (reporter)
2005-11-13 19:02

With aMule-CVS-2005-10-22 source code from amule homepage compiled with libwxgtk 2.6.2-1 from dude.gemil.de debian package repository the memory gets eaten up (from 47 to 77 MB of 92 MB RAM in 48h, then slower decreasing free memory until crash after some days).

With aMule-2.0.3 source code from amule homepage compiled with the same libwxgtk 2.6.2-1 from dude.gemil.de debian package repository the memory usage is stable low at 32 MB of 92 MB RAM.
(0001532)
arichy (reporter)
2005-12-02 10:12

Same problem with cvs-2005-11-30.
There is a thread in forum about it:
http://forum.amule.org/thread.php?threadid=5433 [^]
(0001616)
Kry (manager)
2005-12-09 23:48

Seems to be fixed. A different issue is not being dealt with on forum.

- Issue History
Date Modified Username Field Change
2005-05-23 19:10 philippe landau New Issue
2005-05-26 01:46 Kry Relationship added related to 0000455
2005-05-26 01:46 Kry Note Added: 0001002
2005-07-15 14:14 Xaignar Status new => closed
2005-07-15 14:14 Xaignar Note Added: 0001145
2005-09-10 17:52 philippe landau Status closed => feedback
2005-09-10 17:52 philippe landau Resolution open => reopened
2005-09-10 17:52 philippe landau Note Added: 0001278
2005-11-13 19:02 arichy Note Added: 0001446
2005-12-02 10:12 arichy Note Added: 0001532
2005-12-09 23:48 Kry Status feedback => assigned
2005-12-09 23:48 Kry Assigned To => Kry
2005-12-09 23:48 Kry Status assigned => resolved
2005-12-09 23:48 Kry Fixed in Version => CVS
2005-12-09 23:48 Kry Resolution reopened => fixed
2005-12-09 23:48 Kry Note Added: 0001616


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker