View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000489aMuleMessagespublic2005-06-21 19:452005-11-01 19:25
Reporterconde_lnx 
Assigned ToXaignar 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in VersionSVN 
Summary0000489: Infinite loop write the log "Error in CClientUDPSocket: 4"
DescriptionAfter that amule run two or three hours, it begins to write in the file .xsession-errors this line: "Error in CClientUDPSocket: 4".
The program writes it one and another time, and the size of the file .xssession-errors grows until the hard disk is complete. Then, as the free disk is equal to zero, amule is blocked and I has to kill it with the -9 signal.

Sorry for my words, but my english is very bad.
Additional InformationSystem:
Debian testing
amule CVS (debian repository)
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0001104)
Xaignar (manager)
2005-06-25 16:16

I'm reasonably sure that this is because the UDP socket objects arnt thread-safe, yet we call them from multiple threads. However, I can't say why the messages gets placed in your .xsession-errors file, as they are simply printfs.
(0001111)
conde_lnx (reporter)
2005-06-26 15:35

The messages gets placed in my .xsession-errors file because WindowMaker forwards the standard system out of the launched programs to this file.
(0001112)
Xaignar (manager)
2005-06-26 21:26

Ah, I see. Then I'd suggest that you start aMule from a console until we've fixed the problem.

Cheers,
 Xaignar
(0001383)
Xaignar (manager)
2005-10-30 20:37

I have committed a patch that should fix this issue.
Please let us know if you still have problems.

Cheers,
 Xaignar
(0001388)
conde_lnx (reporter)
2005-11-01 12:50

It works fine, thanks

- Issue History
Date Modified Username Field Change
2005-06-21 19:45 conde_lnx New Issue
2005-06-25 16:13 Xaignar Status new => assigned
2005-06-25 16:13 Xaignar Assigned To => Xaignar
2005-06-25 16:16 Xaignar Note Added: 0001104
2005-06-26 15:35 conde_lnx Note Added: 0001111
2005-06-26 21:26 Xaignar Note Added: 0001112
2005-10-30 20:37 Xaignar Status assigned => resolved
2005-10-30 20:37 Xaignar Fixed in Version => CVS
2005-10-30 20:37 Xaignar Resolution open => fixed
2005-10-30 20:37 Xaignar Note Added: 0001383
2005-11-01 12:50 conde_lnx Status resolved => feedback
2005-11-01 12:50 conde_lnx Resolution fixed => reopened
2005-11-01 12:50 conde_lnx Note Added: 0001388
2005-11-01 19:25 Xaignar Status feedback => resolved
2005-11-01 19:25 Xaignar Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker