View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000052aMuleFeature Requestpublic2004-05-27 03:502004-06-23 11:38
ReporterMarcel 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000052: aMule crash on SuSE 9.1
DescriptionaMule crash on connect to any servr on SuSE 9.1 or in some actions, a have already try glib for i586 and glib for i686 (default )

cpu: Athlon 2000

Additional Informationconsole output always the same from OOPS:

Loading temp files from /home/marcel/.aMule/Temp/*.part.met.
Hashing thread timed out with no aditions - removing thread
Hashing thread ended

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

[0] amule(_ZN9CamuleApp16OnFatalExceptionEv+0xdf) [0x81d5d5f]
[1] /usr/lib/libwx_gtk2-2.4.so.0(wxFatalSignalHandler+0x2b) [0x403dcd4b]
[2] [0xffffe420]
[3] /usr/lib/libwx_gtk2-2.4.so.0(_ZNK8wxDCBase13GetTextExtentERK8wxStringPiS3_S3_S3_P6wxFont+0x3e) [0x402d6c6e]
[4] amule(_ZN16wxODListLineData17DrawTextFormattedEP4wxDCRK8wxStringiiii+0x65) [0x8140045]
[5] amule(_ZN16wxODListLineData16DrawInReportModeEP4wxDCRK6wxRectS4_b+0x284) [0x81421a4]
[6] amule(_ZN18wxODListMainWindow7OnPaintER12wxPaintEvent+0x6bf) [0x814388f]
[7] /usr/lib/libwx_gtk2-2.4.so.0(_ZN12wxEvtHandler16SearchEventTableER12wxEventTableR7wxEvent+0xc3) [0x402f3213]
[8] /usr/lib/libwx_gtk2-2.4.so.0(_ZN12wxEvtHandler12ProcessEventER7wxEvent+0x83) [0x402f33a3]
[9] /usr/lib/libwx_gtk2-2.4.so.0(_ZN8wxWindow18GtkSendPaintEventsEv+0x195) [0x40299215]
[10] /usr/lib/libwx_gtk2-2.4.so.0 [0x4029d6ba]
[11] /opt/gnome/lib/libgtk-x11-2.0.so.0(_gtk_marshal_BOOLEAN__BOXED+0xb4) [0x405fd264]
[12] /usr/local/lib/libgobject-2.0.so.0(g_closure_invoke+0xfc) [0x40876aac]
[13] /usr/local/lib/libgobject-2.0.so.0 [0x40885561]
[14] /usr/local/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x660) [0x40886850]
[15] /usr/local/lib/libgobject-2.0.so.0(g_signal_emit+0x26) [0x40886d96]
[16] /opt/gnome/lib/libgtk-x11-2.0.so.0 [0x406d99b4]
[17] /opt/gnome/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x4a9) [0x405f8d89]
[18] /opt/gnome/lib/libgdk-x11-2.0.so.0 [0x407a0be7]
[19] /opt/gnome/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0x67) [0x407a0d97]
[20] /opt/gnome/lib/libgdk-x11-2.0.so.0 [0x407a0dff]
[21] /usr/local/lib/libglib-2.0.so.0 [0x408ca851]
[22] /usr/local/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1a7) [0x408cc257]
[23] /usr/local/lib/libglib-2.0.so.0 [0x408ce6f9]
[24] /usr/local/lib/libglib-2.0.so.0(g_main_loop_run+0x218) [0x408cf6e8]
[25] /opt/gnome/lib/libgtk-x11-2.0.so.0(gtk_main+0xbf) [0x405f911f]
[26] /usr/lib/libwx_gtk2-2.4.so.0(_ZN5wxApp8MainLoopEv+0x17) [0x4023f627]
[27] /usr/lib/libwx_gtk2-2.4.so.0(_ZN9wxAppBase5OnRunEv+0x2f) [0x4029eeaf]
[28] /usr/lib/libwx_gtk2-2.4.so.0(_Z7wxEntryiPPc+0x273) [0x40240093]
[29] amule(main+0x1b) [0x81d928b]
[30] /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x41120500]
[31] amule(_ZN10wxNotebook12SetSelectionEi+0x45) [0x80cdd21]
Abortado

TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0000080)
Marcel (reporter)
2004-05-27 03:54

Sorry my amule vertion is
2.0 rc3

pls excuse my bad english
(0000081)
Xaignar (manager)
2004-05-27 10:45

Your copy of wxGTK seems to be linked against GTK2. This is not recommended at the moment, so I suggest that you install a version linked against GTK1. You can find more information on how to do that here, if your distro does not provide the correct binaries: http://www.amule.org/wiki/index.php/Compilation_Installation [^]

Also, in the future, pleaes only post backtraces in the backtraces forum, not on the buglist.

Cheers,
 Xaignar
(0000082)
Marcel (reporter)
2004-05-28 03:42

Yes that should make the trick, but i already install wxBASE and wxGTK from your web site ( yes i first uninstalled )

Before I make that i could not even install aMule.

But I try xMule and work fine, thanks any way.

"./configure --prefix=/usr --disable-debug --enable-final --with-gtk --disable-profile"

sorry about that

and sorry for my realy bad english.
(0000083)
Marcel (reporter)
2004-05-28 04:28

""./configure --prefix=/usr --disable-debug --enable-final --with-gtk --disable-profile"
 
 sorry about that"

again sorry i mean sorry about:
"Also, in the future, pleaes only post backtraces in the backtraces forum, not on the buglist."

I just discovered that the crash is when i connect to a server, if i don`t stay up with no problems.
(0000088)
Xaignar (manager)
2004-05-29 20:47

I have a bit difficulti following you. Is the crash still happening after you installed a copy of wxGTK linked to GTK1? If it is, please post a backtrace in the backtraces forum. If not (if it's the same as above), then we are aware of the cause and are working on fixing it.

Cheers,
 Xaignar
(0000110)
Xaignar (manager)
2004-06-23 11:38

Closing bug as no further information was given. Presuming that the issue was resolved.

- Issue History
Date Modified Username Field Change
2004-05-27 03:50 Marcel New Issue
2004-05-27 03:54 Marcel Note Added: 0000080
2004-05-27 10:45 Xaignar Status new => closed
2004-05-27 10:45 Xaignar Note Added: 0000081
2004-05-28 03:42 Marcel Status closed => feedback
2004-05-28 03:42 Marcel Resolution open => reopened
2004-05-28 03:42 Marcel Note Added: 0000082
2004-05-28 04:28 Marcel Note Added: 0000083
2004-05-29 20:47 Xaignar Note Added: 0000088
2004-06-23 11:38 Xaignar Status feedback => closed
2004-06-23 11:38 Xaignar Note Added: 0000110


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker