View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000059aMuleMiscpublic2004-06-02 08:122005-02-07 05:29
ReporterJacobo221 
Assigned ToKry 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000059: bugs in current CVS (2 June 2004) on wx 2.4.2
DescriptionThis applies to current CVS (2 June 2004) on wx 2.4.2 (GTK1.2)
Bugs currently noticed are:
- A dialog is displayed if ~/.aMule/ipfilter.dat doesn't exist.
- Instead, if it does exist, it crashes on startup (created with `touch ~/.aMule/ipfilter.dat`)
- At the bottom status texts, it shows "Users: x" instead of "Users x(y) | Files: z(t)" as it should.
- On server tab, at the top, it displays "Servers (", so it doesn't show the number of servers known neither the closing parenthesis.
- On transfers tab, clients in queue shows a number which doesn't correspnd at ll neither with the clients uploading from me neither with the clients waiting on my upload queue.
- Also on transfers tab, the tabs that switch between the different groups are half hidden.
- Still on transfers tab, at the top, it shows (right after clicking on the transfers list) "Downloads (x)", where "(x)" is overlapped by the groups tabs.
- Last on transfers tab, the "shows upload/up-queue" button is now displayed too much to the right of the window.
- Now on SharedFiles tab, at the bottom, on the "Transferred" line, it shows "X bytes" twice, but bith times it is only seen "by", since the rest of the word is overlapped by the input boxes.
- In search tab, "Copy ED2K link to clipboard" isn't managing special non-ASCII characters at all (it ignores them).

And that's it.
I'm now compiling on 2.5.1 so, to be continued... ;-)
Additional InformationAs an addition: Why not making the the scrolling on the statics tab faster? it's quite annoying to go through the entire statics dialog with the mouse's scroll wheel :-/
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0000091)
Madcat (manager)
2004-06-02 08:38

Additionally:
* Clicking on items on shared files list causes roughly 1 second delay
* The queue count issue mentioned above comes again from too small wxTextCtrl width, only the first number is shown.
* The progressbars are too dark by default, the setting in preferences is called rather non-obviously 'flat/round', while it actually changes gamma. And where is the real 'flat/round' option?

Madcat.
(0000092)
Jacobo221 (updater)
2004-06-02 10:38

K, I tried with wx 2.5.1 now. Bugs are... THE SAME! So bugs are pobably related to unicode migration?
I have an observation though (for both 2.5 and 2.5), "Users on queue: x" is not any random number what it is displaying as I thought it was, it's the first digit of the real amount of clients on the queue. So, if there are 9 clients, it displays the correct number, if there are 21, it displays 2, if there are 193, it dpslays 1, etc... Maybe this is because it's just given space to display one character?
I found one more bug: both file details and client details have most of the inputs also partially hidden.
I also think that the weird "Users: x" instead of "Users: x(x) | Files: x(x)" is because it's only given space to show the first 8 characters, so only "Users: x" can be shown :-)
(0000093)
Jacobo221 (updater)
2004-06-02 11:40

More on the same, on status bar, it only allows three chars on the upload and dl speed, so I get weird things such as "10." :-)

- Issue History
Date Modified Username Field Change
2004-06-02 08:12 Jacobo221 New Issue
2004-06-02 08:22 Jacobo221 Description Updated
2004-06-02 08:38 Madcat Note Added: 0000091
2004-06-02 10:38 Jacobo221 Note Added: 0000092
2004-06-02 11:40 Jacobo221 Note Added: 0000093
2004-06-03 02:52 Jacobo221 Status new => resolved
2004-06-03 02:52 Jacobo221 Resolution open => fixed
2005-02-07 05:29 Kry Status resolved => assigned
2005-02-07 05:29 Kry Assigned To => Kry
2005-02-07 05:29 Kry Status assigned => resolved


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker