View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000788aMulePreferencespublic2006-01-16 15:562006-01-17 19:14
ReporterSevein 
Assigned ToXaignar 
PrioritynormalSeveritytweakReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOSOS Version
Product Version2.1.0 
Target VersionFixed in VersionSVN 
Summary0000788: aMule does not create files with amule.conf/PermissionFiles value
DescriptionI wanted to read my files of Incoming directory from other users so I tried to change the permissions with files are created by aMule.

Because I wanted 666 for files, I give to "PermissionsFiles" the value 438 (666). I started aMule, however the file are created with 644. What's wrong?

It seems to be a bug!
Additional InformationPermissionsFiles=438
-rw-r--r-- p2p p2p noon.mp3
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0001795)
Kry (manager)
2006-01-17 08:43

Folder permisions? umask output? Info we need.
(0001797)
Sevein (reporter)
2006-01-17 09:27

(from umask)
umask 0022

(ls -ld to all the parent dirs)
drwxr-xr-x 3 root root 96 Jun 9 2005 /home/
drwxr-xr-x 4 p2p p2p 184 Jan 4 12:26 /home/p2p/
drwx------ 4 p2p p2p 768 Jan 17 09:42 /home/p2p/.aMule/
drwxr-x--- 2 p2p p2p 296 Jan 17 00:43 /home/p2p/.aMule/Incoming/

(from ps aux)
p2p 6916 2.8 9.1 61124 23408 ? Ssl Jan15 69:43 /usr/bin/amuled

(the user)
p2p /home/p2p /bin/false

The user who runs amuled has false shell (included in /etc/shells) because I do not want anyone login with that user.

Something more? All you need.
(0001798)
Sevein (reporter)
2006-01-17 09:29

System uname: 2.6.14.2 i686 Pentium II (Deschutes)
gcc 3.4.4
glibc-2.3.5
(0001799)
Xaignar (manager)
2006-01-17 11:16

Taken from "man 2 umask":
       The umask is used by open(2), mkdir(2), and other system calls
       that create files to modify the permissions placed on newly cre-
       ated files or directories. Specifically, permissions in the umask
       are turned off from the mode argument to open(2) and mkdir(2) (so,
       for example, the common umask default value of 022 results in new
       files being created with permissions 0666 & 0000018:0000022 = 0644 = rw-
       r--r-- in the usual case where the mode is specified to open(2) as
       0666).

In other words, you get your 666 permission, minus the umask, which equals 644.
(0001801)
Sevein (reporter)
2006-01-17 14:57

I understand. However, don't you think aMule should try to set the wished permissions for those files downloaded trying to forget umask? This would give more flexiblity to users who don't prefer to change his umask only for aMule needs.

Thanks for your great support and sorry for my bad English, :).
(0001802)
Xaignar (manager)
2006-01-17 17:04

Actually, it would be less flexible if aMule ignored the umask. You can simply set it to zero with the umask command if you dont wish to have it affect aMule.
(0001803)
Sevein (reporter)
2006-01-17 17:32

Xaignar, I wouldn't like to be annoying with this but if the user set umask to 000 this will affect all his enviroment! Moreover, sometimes, amuled is run by an user without shell or /bin/false like the assigned shell.
(0001804)
Sevein (reporter)
2006-01-17 17:38

My friend rg3 told me I could do this:

myamule.sh
#!/bin/sh
umask 000
exec /ruta/al/amule

Thanks!

- Issue History
Date Modified Username Field Change
2006-01-16 15:56 Sevein New Issue
2006-01-17 08:43 Kry Note Added: 0001795
2006-01-17 09:27 Sevein Note Added: 0001797
2006-01-17 09:29 Sevein Note Added: 0001798
2006-01-17 11:16 Xaignar Note Added: 0001799
2006-01-17 14:57 Sevein Note Added: 0001801
2006-01-17 17:04 Xaignar Status new => resolved
2006-01-17 17:04 Xaignar Fixed in Version => CVS
2006-01-17 17:04 Xaignar Resolution open => no change required
2006-01-17 17:04 Xaignar Assigned To => Xaignar
2006-01-17 17:04 Xaignar Note Added: 0001802
2006-01-17 17:32 Sevein Status resolved => feedback
2006-01-17 17:32 Sevein Resolution no change required => reopened
2006-01-17 17:32 Sevein Note Added: 0001803
2006-01-17 17:38 Sevein Note Added: 0001804
2006-01-17 19:14 Xaignar Status feedback => resolved
2006-01-17 19:14 Xaignar Resolution reopened => no change required


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker