View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000795aMuleFeature Requestpublic2006-01-21 21:482016-04-08 14:49
Reporterarichy 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in Version2.3.1 
Summary0000795: Progress of file completing (after complete download)
DescriptionWhen a file is completely downloaded, it gets completed and copied to the Incoming directory. This process can consume 10-20 minutes on a 600MB file on a Pentium that has to do other things too. So it would be nice to display the progress of completing in percent (maybe the part bar could stay green so one can see: it's completely downloaded, the percentage is related to the completing process). Or the percentage could be given in the status column ("Completing (12%)".
TagsNo tags attached.
Fixed in Revision
Operating SystemAny
Attached Files

- Relationships

-  Notes
(0002879)
Wuischke (manager)
2008-07-14 16:59

Note: The loop is in ThreadTasks.cpp:147, also the function CreateHashFromInput() in KnownFile.cpp:782 might be interesting if one wants more information.
(0003406)
Marcell (developer)
2010-04-04 11:27

Currently implemented for: client, text-client, remote-gui.
Still to come: web-gui
(0003409)
Marcell (developer)
2010-04-10 20:10

Because this required a change in DownloadListCtrl.cpp it can only be committed once the GUI is unlocked by Kry.
Let's hope this will happen soon, because Stu changeing the EC code regularly gives me headaches keeping my working copy working.
(0003427)
Marcell (developer)
2010-05-12 20:00

Implemented in SVN 10149.
(0003430)
sturedman (developer)
2010-05-16 11:26

Not quite...

- Issue History
Date Modified Username Field Change
2006-01-21 21:48 arichy New Issue
2006-01-23 19:43 Xaignar Status new => acknowledged
2008-07-14 16:59 Wuischke Note Added: 0002879
2010-02-01 16:55 Marcell Status acknowledged => assigned
2010-02-01 16:55 Marcell Assigned To => Marcell
2010-04-04 11:27 Marcell Note Added: 0003406
2010-04-10 20:10 Marcell Note Added: 0003409
2010-05-12 20:00 Marcell Note Added: 0003427
2010-05-12 20:00 Marcell Status assigned => resolved
2010-05-12 20:00 Marcell Resolution open => fixed
2010-05-16 11:24 sturedman Note Added: 0003429
2010-05-16 11:24 sturedman Status resolved => feedback
2010-05-16 11:24 sturedman Resolution fixed => reopened
2010-05-16 11:25 sturedman Operating System => Any
2010-05-16 11:25 sturedman Status feedback => assigned
2010-05-16 11:25 sturedman Resolution reopened => open
2010-05-16 11:25 sturedman Product Version 2.1.0 => SVN
2010-05-16 11:26 sturedman Note Deleted: 0003429
2010-05-16 11:26 sturedman Note Added: 0003430
2016-04-08 14:49 GonoszTopi Assigned To Marcell =>
2016-04-08 14:49 GonoszTopi Status assigned => resolved
2016-04-08 14:49 GonoszTopi Resolution open => fixed
2016-04-08 14:49 GonoszTopi Fixed in Version => 2.3.1


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker