View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000805aMuleSharedfilespublic2006-01-30 15:142006-05-24 03:56
Reporterju1i3n 
Assigned ToKry 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version2.1.0 
Target VersionFixed in Version2.1.0 
Summary0000805: Doesn't liberate file deleted from incomming
DescriptionWhen i delete file from incomming folder, even if i push actualise shared file, the disk space is not release until i close aMule(d).

I think that files' handles aren't released when files are removed from shared file list.
Additional Informationamuled
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships

-  Notes
(0001839)
Xaignar (manager)
2006-01-31 11:56

This happens for both aMule and aMuled?
(0001840)
ju1i3n (reporter)
2006-01-31 13:54
edited on: 2006-01-31 18:54

It's happens with aMuled. I've just tested with aMule and this time no problem. But i don't know if there's a problem only if the file is uploading while i delete it, or everytime. It's not very easy to test.

The check with aMule: i delete the file, space is liberated even if the file is in shared list, without pushing actualise button. I don't know if the file was in uploading while deleted.

(Config: Gentoo, 2.4.32-sparc-r1, sparc 64.)

edited on: 01-31-06 18:54
(0001841)
ju1i3n (reporter)
2006-01-31 18:54

New test with aMule: if i delete the file while it's uploading, the diskspace is freed => No probleme with aMule

So only bug with aMuled.
(0001850)
Kry (manager)
2006-02-04 22:14

That's a kernel issue, not aMule. Basically because we keep no open handlers for shared files.

I have seen it only with 2.4 series. Try a 2.6
(0001859)
ju1i3n (reporter)
2006-02-05 15:54

If it's a kernel issue, why is there a probleme only with amuled and not why amule?
(0001875)
Kry (manager)
2006-03-10 05:33

Well, you tell me. As they share same code.
(0002001)
Kry (manager)
2006-05-24 03:56

Closing (NAI / lack of feedback)

- Issue History
Date Modified Username Field Change
2006-01-30 15:14 ju1i3n New Issue
2006-01-31 11:56 Xaignar Note Added: 0001839
2006-01-31 13:54 ju1i3n Note Added: 0001840
2006-01-31 18:54 ju1i3n Note Edited: 0001840
2006-01-31 18:54 ju1i3n Note Added: 0001841
2006-02-04 22:13 Kry Status new => assigned
2006-02-04 22:13 Kry Assigned To => Kry
2006-02-04 22:14 Kry Status assigned => resolved
2006-02-04 22:14 Kry Fixed in Version => 2.1.0
2006-02-04 22:14 Kry Resolution open => fixed
2006-02-04 22:14 Kry Note Added: 0001850
2006-02-05 15:54 ju1i3n Status resolved => feedback
2006-02-05 15:54 ju1i3n Resolution fixed => reopened
2006-02-05 15:54 ju1i3n Note Added: 0001859
2006-03-10 05:33 Kry Note Added: 0001875
2006-05-24 03:56 Kry Status feedback => closed
2006-05-24 03:56 Kry Note Added: 0002001


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker