View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000680aMuleMulti Platformpublic2005-12-02 14:342007-11-18 06:04
ReporterD10Tmain 
Assigned ToKry 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in VersionSVN 
Summary0000680: endians issue in source exchange ?
Descriptioni log i've got:

2005-12-02 13:35:15: IPFilter: Filtered IP (AccLvl: 0): 182.234.85.83 (Not declared, Invalid, SMART Technologies, Inc)
2005-12-02 13:35:15: IPFilter: Ignored source (IP=182.234.85.83) received via source exchange - IPfilter
2005-12-02 13:35:15: IPFilter: Filtered IP (AccLvl: 0): 182.234.85.83 (Not declared, Invalid, SMART Technologies, Inc)
2005-12-02 13:35:15: IPFilter: Ignored source (IP=182.234.85.83) received via source exchange - IPfilter
2005-12-02 13:35:15: IPFilter: Filtered IP (AccLvl: 0): 175.35.22.83 (Not declared, Invalid, SMART Technologies, Inc)
2005-12-02 13:35:15: IPFilter: Ignored source (IP=175.35.22.83) received via source exchange - IPfilter
2005-12-02 13:35:15: IPFilter: Ignored source (IP=226.197.150.194) received via source exchange - bad IP
2005-12-02 13:35:15: IPFilter: Filtered IP (AccLvl: 0): 165.133.31.83 (Daewoo Telecom Ltd, Not declared)
2005-12-02 13:35:15: IPFilter: Ignored source (IP=165.133.31.83) received via source exchange - IPfilter


and i`m 100% sure these adresses are in reverse order - should be 83.x.x.x
is it amule issue or other client sending this info ?

ibm rs6k power3, RHEL4 UP2, amule and wx compiled as 32bit
amule CVS 20051127
TagsNo tags attached.
Fixed in Revision
Operating SystemAny
Attached Files

- Relationships
related to 0000841resolvedKry endian issue in KAD 

-  Notes
(0001535)
Xaignar (manager)
2005-12-02 16:04

Can you tell me which IPFilter.dat file you are using?
(0001536)
D10Tmain (reporter)
2005-12-03 00:35

latest v95 from http://emulepawcio.sourceforge.net/nieuwe_site/Ipfilter_fakes/ipfilter.zip [^]
and i dont think it`s ipfilter issue but maybe source exchange part of amule

83.x.x.x it`s network of my national provider
i can without any problem download/upload from/to this network clients when i get sources from kad or server.
the issue exist only when source address commes from source exchange. i cant figure if another client is sending adresses with reversed bytes or amule incorrectly process packets in source exchange protocol.
(0001537)
D10Tmain (reporter)
2005-12-03 00:47

i`ve forgot
that log entries only exist sometimes just after amule startup.
(0001539)
Xaignar (manager)
2005-12-03 02:29

Ok, may I ask what makes you think the sources have the IP swapped? I'll review the code in the mean time.
(0001540)
Xaignar (manager)
2005-12-03 02:48

Hum, seems that you are right. I'll commit a fix and have some of the other devs review it. Thanks for the report.
(0001541)
D10Tmain (reporter)
2005-12-03 04:25

1 the last byte in addresses from log all are x.x.x.83
2 i have many clients from network 83.x.x.x
3 other addresses like 226.197.150.194 (multicast)

that was signals 4 me that bytes are swapped - but in which moment:
- other client sending to network with wrong byte order
- or amule not correctly process incomming source list from source exchange

thx :-)
(0001544)
Xaignar (manager)
2005-12-03 13:57

The problem seem to be that aMule is swapping the IP of clients received via v3 source-exchange. It a bit more wide-spread than I initially thought, so a fix will have to wait till I can speak with our Mac developer (it's a Mac only problem).
(0001546)
D10Tmain (reporter)
2005-12-04 01:00

one swap 2 far ;-)

so it`s only ppc cpu issue ? on intel it`s ok ?
(0001896)
Kry (manager)
2006-03-21 05:58

solvedy solvedy
(0002128)
D10Tmain (reporter)
2006-09-28 12:35

yesterday i`ve recompiled CVS snapshot (2006.09.27) and i think the issue is back :(

from log (swapped bytes in ips)

2006-09-28 12:23:08: IPFilter: Ignored source (IP=92.0.70.61) received via Source Exchange - IPfilter
2006-09-28 12:23:08: IPFilter: Filtered IP (AccLvl: 70): 203.0.54.89 ([BG]UnAv)
2006-09-28 12:23:08: IPFilter: Ignored source (IP=203.0.54.89) received via Source Exchange - IPfilter
2006-09-28 12:23:08: IPFilter: Filtered IP (AccLvl: 90): 16.5.252.201 ([L1]Apple Computer,Inc)
2006-09-28 12:23:08: IPFilter: Ignored source (IP=16.5.252.201) received via Source Exchange - IPfilter
2006-09-28 12:23:08: IPFilter: Ignored source (IP=248.183.96.212) received via Source Exchange - bad IP

- Issue History
Date Modified Username Field Change
2005-12-02 14:34 D10Tmain New Issue
2005-12-02 16:04 Xaignar Note Added: 0001535
2005-12-03 00:35 D10Tmain Note Added: 0001536
2005-12-03 00:47 D10Tmain Note Added: 0001537
2005-12-03 02:29 Xaignar Note Added: 0001539
2005-12-03 02:48 Xaignar Note Added: 0001540
2005-12-03 04:25 D10Tmain Note Added: 0001541
2005-12-03 13:57 Xaignar Note Added: 0001544
2005-12-04 01:00 D10Tmain Note Added: 0001546
2005-12-05 20:03 Xaignar Status new => assigned
2005-12-05 20:03 Xaignar Assigned To => ken
2006-03-15 16:06 Kry Relationship added related to 0000841
2006-03-21 05:57 Kry Assigned To ken => Kry
2006-03-21 05:58 Kry Status assigned => resolved
2006-03-21 05:58 Kry Fixed in Version => CVS
2006-03-21 05:58 Kry Resolution open => fixed
2006-03-21 05:58 Kry Note Added: 0001896
2006-09-28 12:35 D10Tmain Operating System => Any
2006-09-28 12:35 D10Tmain Status resolved => feedback
2006-09-28 12:35 D10Tmain Resolution fixed => reopened
2006-09-28 12:35 D10Tmain Note Added: 0002128
2007-08-19 14:04 Kry Status feedback => resolved
2007-08-19 14:04 Kry Resolution reopened => fixed
2007-11-18 06:04 phoenix Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker