View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001248aMuleMiscpublic2008-01-26 15:032008-08-13 16:28
Assigned To 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in Version 
Summary0001248: aMule hogs lots of memory and then dies
DescriptionI have OpenSuse 10.3. The problem came originally with an older CVS version found in Suse servers. Now I compiled the latest version aMule-CVS-20080125. I get the same problem still.

The program runs fine for an hour at least. Memory usage remains constant. Then it starts to eat more and more memory and finally dies. It is like a memory leak which is triggered by something. No user action is involved though.

I compiled with the default "configure" settings. Should I make the "real backtrace" thing?

Juha Manninen
Additional Information--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here: [^]
If possible, please try to generate a real backtrace of this crash: [^]

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.4 (Snapshot: Fri Jan 25 07:01:56 CET 2008)
Running on: Linux i686

[2] CamuleApp::OnFatalException() in amule.cpp:1301
[3] wxFatalSignalHandler in /usr/lib/[0xb7ad5666]
[4] ?? in [0xffffe420]
[5] ?? in /usr/lib/ [0xb7ca5814]
[6] ?? in /usr/lib/ [0xb7397c4f]
[7] ?? in /usr/lib/ [0xb727cd2d]
[8] g_main_context_dispatch in /usr/lib/[0xb724d5d6]
[9] ?? in /usr/lib/ [0xb7250972]
[10] g_main_loop_run in /usr/lib/[0xb7250d57]
[11] gtk_main in /usr/lib/[0xb754a244]
[12] wxEventLoop::Run() in /usr/lib/[0xb7ca3d7c]
[13] wxAppBase::MainLoop() in /usr/lib/[0xb7d44f3c]
[14] wxAppBase::OnRun() in /usr/lib/[0xb7d44511]
[15] wxEntry(int&, wchar_t**) in /usr/lib/[0xb7a65ffa]
[16] wxEntry(int&, char**) in /usr/lib/[0xb7a660a7]
[17] main in amule-gui.cpp:92
[18] __libc_start_main in /lib/[0xb778dfe0]
[19] wxAppBase::MainLoop() in amule[0x8071ed1]


Another little different error:

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.4 (Snapshot: Fri Jan 25 07:01:56 CET 2008)
Running on: Linux i686

Muistialueen ylitys (--> means "memory area overflow")
TagsNo tags attached.
Fixed in Revision
Operating SystemOpenSuse 10.3
Attached Files

- Relationships
related to 0001359closed aMuled 2.2.1 high memory usage 

-  Notes
Xaignar (manager)
2008-01-26 18:58

Hmm, can you try upgrading to the latest wxWidgets (2.8.7)? Also, yeah, creating a real backtrace is always preferable from our point of view. :)

More information here: [^]

JuhaManninen (reporter)
2008-01-26 19:55

I tried to run aMule in gdb to get the real backtrace.
After 3 hours of running it started to hog all memory, including swap, and the machine practically halted. After another hour or 2 the program died with:
"Program terminated with signal SIGKILL, Killed."
"The program no longer exists."

When I tried to get the output from gdb, it said:
"No stack." and
"No registers."

The aMule program was the exact same compilation as earlier.

Juha Manninen
JuhaManninen (reporter)
2008-01-27 00:21


I compiled wxWidgets 2.8.7 with unicode support, and then compiled aMule again. Now it has been running at least 3 hours without problems. Seems like this solved the case. Thanks for help!

Suse's packages for wxWidgets really should be updated.

Juha Manninen
JuhaManninen (reporter)
2008-01-27 01:59

Oops... almost.

The problem is not gone, I was too eager to send a note here.
After 2 more hours the memory usage started to rise again just like before. It ate all memory, also swap, and then finally died with:

Terminated after throwing an instance of 'std::bad_alloc'
        what(): std::bad_alloc
* Could not get symbol names for backtrace

(process:21982): GLib-ERROR (recursed) **: gmem.c:172: failed to allocate 32 bytes


Am I really the only person with this problem? At least the other bug reports didn't complain about it. Could it be Suse related? Some other library still?
The new wxWidgets version is now used for sure when compiling.

Juha Manninen
JuhaManninen (reporter)
2008-01-27 11:23

Added a backtrace at "". [^]
Is it helpfull?

Juha Manninen
Xaignar (manager)
2008-01-27 13:01

I'm afraid that the backtrace is not very useful. Please be sure to compile aMule with debugging enabled (--enable-debug) and don't strip the binary, as this makes backtraces much harder to read.
Coronas (reporter)
2008-01-31 08:29

I experience a similar problem with amuled. It will only run for a very short time, sometimes half an hour, sometimes just 5 minutes. After that, the memory consume rises skyhigh, and the app dies. Unfortunately, I can't produce a good backtrace as amuled is running on an embedded device with memory restrictions. Anyway, my workaround was to leave KAD disconnected and work only with the ed2k network. That got definately rid of the problem.
mr_hyde (reporter)
2008-02-02 10:01
edited on: 2008-02-02 10:11

I don't know if my experience can be useful: I hav the problem with amule (never seen with amuled, yes, just the contrary of Coronas), and I observed that amule at beginning works correctly then, (sometimes after some minutes and sometimes after hours), the %CPU value of top command rises near 100% (I have a laptop and I can hear the fan noise) and also the MEM value increases quickly, and at this point PC becomes slow and does not respond to user anymore. Maybe a strange loop? And/or probably I used wrong settings for my network connection? I have fibre connection with 10 Mbit for uploads and 10 Mbit for download, I set 1220 kB/s as download limit, 800 kB/sas upload limit, 40 kB/S for slot allocation and 200 as connection limits, my PC has 2G of RAM.
And just another question: kernel configuration (scheduler and similar settings) may have some influence with amule?

edited on: 02-02-08 10:11
antonovich (reporter)
2008-03-24 17:32

I can confirm that I had this problem with both 2.1.3 on ubuntu 7.10 and now svn on 8.04 beta. It seems to be pretty random but never seems to go more than a day or so now (could last up to 3 or 4 with the stable version). Memory seems to slowly increase (probably with the queue size) and then all of a sudden it will go out of control. I have 6GB of RAM... and when it starts taking 5.8GB it's time for a kill!
Wuischke (manager)
2008-07-21 17:59

Can someone confirm this for current versions? (2.2.1, current SVN)
pcmaster (reporter)
2008-07-22 12:53
edited on: 2008-07-22 12:53 [^]

It not dies, but it has high memory usage.

edited on: 07-22-08 12:53
Wuischke (manager)
2008-08-13 16:28

I will close this bug report for now as the original problems doesn't seem to exist anymore. The memory problem however seems to be serious.

- Issue History
Date Modified Username Field Change
2008-01-26 15:03 JuhaManninen New Issue
2008-01-26 15:03 JuhaManninen Operating System => OpenSuse 10.3
2008-01-26 18:58 Xaignar Note Added: 0002541
2008-01-26 19:55 JuhaManninen Note Added: 0002542
2008-01-27 00:21 JuhaManninen Note Added: 0002543
2008-01-27 01:59 JuhaManninen Note Added: 0002544
2008-01-27 11:23 JuhaManninen Note Added: 0002545
2008-01-27 13:01 Xaignar Note Added: 0002546
2008-01-31 08:29 Coronas Note Added: 0002549
2008-02-02 10:01 mr_hyde Note Added: 0002550
2008-02-02 10:11 mr_hyde Note Edited: 0002550
2008-03-24 17:32 antonovich Note Added: 0002755
2008-03-24 17:32 antonovich Note Added: 0002756
2008-03-24 17:33 antonovich Note Added: 0002757
2008-03-24 21:49 Xaignar Note Deleted: 0002757
2008-03-24 21:49 Xaignar Note Deleted: 0002756
2008-07-21 17:59 Wuischke Note Added: 0002883
2008-07-21 17:59 Wuischke Status new => feedback
2008-07-22 12:53 pcmaster Note Added: 0002884
2008-07-22 12:53 pcmaster Note Edited: 0002884
2008-08-13 16:26 Wuischke Relationship added related to 0001359
2008-08-13 16:28 Wuischke Status feedback => closed
2008-08-13 16:28 Wuischke Note Added: 0002908

Copyright © 2000 - 2023 MantisBT Team
Powered by Mantis Bugtracker