View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001262aMuleExternal Connpublic2008-02-16 10:532008-06-06 03:07
Assigned To 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in Version 
Summary0001262: Kad firewalled when only scrambled connections are accepted
DescriptionWhen "only accept scrambled connections" is checked in the preferences (security menu), Kad status tends to say "firewalled" after a delay. It turns green again when the setting is unchecked, but again only after a delay.
Additional InformationKubuntu gutsy 64b
amule_20080123-1nadock1_amd64.deb found on the forum
TagsNo tags attached.
Fixed in Revision
Operating SystemLinux 2.6.22
Attached Files

- Relationships

-  Notes
Brezhonneg (reporter)
2008-02-25 15:10

Just a quick note to say that when I say 'scrambled connections' you possibly should read 'obfuscated connections'... the french translation was somewhat misleading.
Xaignar (manager)
2008-02-25 18:39

Can you tell me which of the 3 obfuscation options you have enabled?
Brezhonneg (reporter)
2008-03-04 11:33

I will try and reproduce, but it takes some time. I'm pretty sure I had the 3 checkboxes ticked when Kad showed as firewalled, and the last one (only accept obfuscated connexions) needed to be unticked to get a green Kad. I don't think I ever unticked the first two at that time.

I'll get back to you to confirm when I manage to reproduce this.
GonoszTopi (administrator)
2008-05-05 03:02

The first *Mule to support obfuscated connections via Kad is eMule0.49a
Current aMule SVN still does not support it.
Brezhonneg (reporter)
2008-05-29 10:01


I have yet another observation concerning the interaction between Kad and the obfuscation settings. I am now using SVN 4 May.

I just ran a test on a newly released file. I have ED2K completely disabled, and am running only Kad. When I check the outgoing obfuscation option (2nd one of the three), aMule sees some sources for the file at startup but cannot connect to any of them. The sources column reports something like 0/20, and a second later 0/10, 0/9, etc... and finally 0. I cannot connect to anybody, the bar stays all red.

Now if I un-check that option, letting only the first one checked (obfuscation support), aMule still sees the sources (0/20) but manages to connect to each of them. Big blue bar, sources at 20.

I tried that repeatedly, and consistently obtained the same result with each of the two settings. That tells me that even though obfuscation is not supported for Kad, the obfuscation settings do have a bad effect on it.

I hope that helps.
Brezhonneg (reporter)
2008-06-02 05:22

Also, I confirm what I reported earlier somewhere else (forum maybe): with that same config (KAD only, only the first obfuscation checkbox ticked), I am only sending to people who support obfuscation too. All the people I am sending to have the blue key on their icon. Looking at the sources, I am sure their should be more people to send to, but those with no blue key get rejected and I am not sending to them.

There are very few exceptions to this though, and I am sometimes sending to people with no blue key, but this is extremely rare.
Brezhonneg (reporter)
2008-06-06 03:07

OK, after some more observations, I get to think that there are actually 2 bugs:

1/ The obfuscation settings have an effect on KAD uploads and downloads, which is not correct, since obfuscation is not supported on KAD yet

2/ The obfuscation settings checkboxes do not have the effect they should have. When the first checkbox is ticked (obfuscation supported), it actually triggers the second setting (outgoing connexions obfuscation). When the second checkbox is ticked (outgoing connexions obfuscation), it actually triggers the third setting (accept only obfuscated connexions).

To support bug 0000002, please re-read my previous reports here. I also add this extra piece of information: when I untick all the obfuscation settings, I can upload to everybody again (even to people with no blue key on their icon).

This is confirmed on SVN Jun 5.


- Issue History
Date Modified Username Field Change
2008-02-16 10:53 Brezhonneg New Issue
2008-02-16 10:53 Brezhonneg Operating System => Linux 2.6.22
2008-02-25 15:10 Brezhonneg Note Added: 0002685
2008-02-25 18:39 Xaignar Note Added: 0002688
2008-03-04 11:33 Brezhonneg Note Added: 0002709
2008-03-08 10:05 GonoszTopi Status new => feedback
2008-05-05 03:02 GonoszTopi Note Added: 0002800
2008-05-05 03:02 GonoszTopi Status feedback => confirmed
2008-05-29 10:01 Brezhonneg Note Added: 0002821
2008-06-02 05:22 Brezhonneg Note Added: 0002822
2008-06-06 03:07 Brezhonneg Note Added: 0002826

Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker