View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001813aMuleMiscpublic2021-07-20 09:442021-07-20 09:44
Reporterwdc 
Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001813: Crash on startup
DescriptionAfter Linux 5.13 computer freeze amule fails to start:
$ amule
01:03:12: Initialising aMule 2.3.3 compiled with wxGTK2 v3.0.5 and Boost 1.75
01:03:12: Checking if there is an instance already running...
01:03:12: No other instances are running.
01:03:22: ListenSocket: Ok.
Trace/breakpoint trap (core dumped)

It only shows message where it complains my Port= is already used, yet "ss|grep portnumber" does not return anything.

coredumpctl info 1286095 here: https://bin.disroot.org/?4455aad2e2521efb#FXuDCi8jHRo1Ces8m1pnpDJJBJCA5o7ERZk69oAfgsdH [^]

i can send .zst file if You tell me where to send it in private

after checking ~/.aMule/logfile, among las lines was:
Error creating UDP socket 0.0.0.0 58291 : Address already in use
MuleUDPSocket: Failed to create valid Server UDP-Socket

this port was used by another app and after i killed that app, the amule started, though i think this is a bug and program should not crash and instead report the issue in STDOUT or suggest where to change this port to something else or such.
TagsNo tags attached.
Fixed in Revision
Operating SystemLinux Manjaro/Arch
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2021-07-20 09:44 wdc New Issue


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker