View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001491aMuleMiscpublic2009-02-10 05:502010-07-06 17:09
Assigned ToGonoszTopi 
PlatformOSOS Version
Product Version2.2.2 
Target VersionFixed in Version2.3.1 
Summary0001491: UTF-8 filenames become weird characters both in the 'transfers' view and on the disk.
DescriptionBoth 'amule' and 'amuled' (2.2.2 using wxGTK2 v2.8.8) shipped with Ubuntu 8.10 have the same problem that Chinese filenames (encoded in UTF-8) embeded in ed2k links become weird characters both in the 'transfers' view and on the disk.
Additional InformationI ran a simple test and found: only when a link is clicked locally (so added to the local 'amule' or 'amuled' via 'ed2k') the Chinese filenames is correct. If I copy the link location and add it manually to the local 'amule', the Chinese filename is incorrect. If a link is clicked remotely (so added to the remote 'amule' or 'amuled' via 'amulecmd') the Chinese name is incorrect.

So, it seems that only 'ed2k' handles UTF-8 filesnames (the ones embeded in the ed2k links) correctly, while 'amulecmd' and 'amule' fail to handle UTF-8.
TagsNo tags attached.
Fixed in Revision10229
Operating SystemUbuntu Linux 8.10
Attached Files

- Relationships
related to 0001402closed filename characters irrecognizable 

-  Notes
sturedman (developer)
2009-02-22 21:29

Works for me (on Windows).
Does copy/paste of Chinese characters work at all on your computer?
Wuischke, could you reproduce it?
Wuischke (manager)
2009-02-23 15:14
edited on: 2009-02-23 18:40

Stu: Yes, I could. I take it you are an Opera user like I am? ;-)

On Linux, this problem is related to Firefox. When copying a link, chinese (i.e. extended unicode) characters will be turned into a %-sequence.

[生死朗读] gets converted to %5B%E7%94%9F%E6%AD%BB%E6%9C%97%E8%AF%BB%5D which aMule displays as [\u00e7\u0094\u009f\u00e6\u00ad\u00bb\u00e6\u009c\u0097\u00e8\u00af\u00bb] (These are not the characters, but the unicode codes.)

aMule's %-sequence conversion assigns every %-sequence an unicode-character, but it should convert multiple codes according to unicode-rules.

When using the ed2k-utility "raw" unicode-values are used and everything works as expected.

Interim solution: Use Opera or ed2k. I can't promise a real solution anytime soon, however.

Edit: Bug reporting software stupid. Not displaying chinese characters correctly. Anyway, I hope you get the point nonetheless.

Edit2: User stupid, too. Can't distinguish "forum" and "bug reporting".

edited on: 02-23-09 15:16

edited on: 02-23-09 18:40
rj (reporter)
2009-03-04 01:45

I tried to use Opera with ed2k on Linux.
1) goto [^]
2) click any of the ed2k link, and in my xterm (where I run "opera &" ), I got this error:

Link successfully queued.
Failed to open ED2KLinks file.
rj (reporter)
2009-03-04 02:02

Here is the message from the /home/rj/.aMule/logfile:

2009-03-04 01:00:37: Error: Failed to convert file "/home/rj/.aMule/ED2KLinks" to Unicode.
Wuischke (manager)
2009-03-06 09:42

What is the output of "locale" in a terminal?
rj (reporter)
2009-03-08 23:25

output from "locale" from my xterm (where I ran amule)

jimhuyiwei (reporter)
2009-04-10 18:50

I can confirm this problem.
jimhuyiwei (reporter)
2009-04-10 18:50

I can confirm this problem.

- Issue History
Date Modified Username Field Change
2009-02-10 05:50 tian New Issue
2009-02-10 05:50 tian Operating System => Ubuntu Linux 8.10
2009-02-10 16:30 Wuischke Status new => acknowledged
2009-02-22 21:29 sturedman Note Added: 0003084
2009-02-23 15:14 Wuischke Note Added: 0003085
2009-02-23 15:16 Wuischke Note Edited: 0003085
2009-02-23 18:40 Wuischke Note Edited: 0003085
2009-03-04 01:45 rj Note Added: 0003091
2009-03-04 01:45 rj Note Added: 0003092
2009-03-04 01:46 rj Note Deleted: 0003092
2009-03-04 02:02 rj Note Added: 0003093
2009-03-06 09:42 Wuischke Note Added: 0003095
2009-03-08 23:25 rj Note Added: 0003096
2009-04-10 18:50 jimhuyiwei Note Added: 0003113
2009-04-10 18:50 jimhuyiwei Note Added: 0003114
2010-07-06 17:09 GonoszTopi Fixed in Revision => 10229
2010-07-06 17:09 GonoszTopi Assigned To => GonoszTopi
2010-07-06 17:09 GonoszTopi Status acknowledged => resolved
2010-07-06 17:09 GonoszTopi Resolution open => fixed
2010-07-06 17:09 GonoszTopi Fixed in Version => 2.3.1
2010-07-07 22:08 GonoszTopi Relationship added related to 0001402

Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker