View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000183aMuleMiscpublic2004-11-04 23:042004-12-09 18:28
Reporterken 
Assigned ToKry 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformMacOSOS XOS Version10.3.5
Product Version 
Target VersionFixed in Version 
Summary0000183: [Mac] No Edit menu or Cut, Copy, Paste functionality
DescriptionThere is no Edit menu. This means that cut and paste doesn't work anywhere. In particular, it renders the ED2K Link Handler field pretty useless. Some of the text boxes provide edit commands in a context menu, but they don't seem to really work except Clear and Select All.
Steps To Reproduce1) Copy some text from any source (e.g. this text in your browser) to the clipboard.
2) Run aMule.
3) Click in the ED2K Link Handler text edit field to give it focus.
4) Press Command-V to paste text there.
5) Observe no effect.
6) Control-click (or right-click) in the field to produce a context menu. Observe that "Paste" is disabled. Dismiss context menu.
7) Type some text (different from that copied in step 1) into the field. Select it.
8) Press Command-C to copy it to the clipboard.
Launch TextEdit.
9) Press Command-V to paste the clipboard contents into the new TextEdit document.
10) Observe that the pasted text is that which was selected in step (1), not what was typed and copied in steps (7) and (8).
11) Go back to aMule and use the context menu to Copy the text from the text field.
12) Go back to TextEdit and try to paste the text again.
13) Notice that the pasted text is still that from step (1).
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Files

- Relationships
related to 0000187resolvedKry Error when attempting to copy ED2K link for any server or file 

-  Notes
(0000389)
Kry (manager)
2004-11-19 05:31

The ed2k box and other boxes have a perfectly working copy/paste popup here. So what's up at yours? related to 0000187
(0000404)
ken (developer)
2004-11-21 11:00

Works now with Mac rc8 prerelease. Command key combinations for Paste, Cut, Copy work. Delete key works for Clear command. However, Command-A doesn't work for Select All.
(0000408)
Kry (manager)
2004-11-21 20:28

Closing (about select all, you'll have to wait till wxWidgets fix that :))
(0000419)
ken (developer)
2004-12-05 04:56

This seems to have come back in the version you gave me via IRC. Here's a new hypothesis that I haven't yet tested: It works when aMule first starts up, but begins to fail at some point during the run. It may be (or be related to) a memory issue.
(0000440)
ken (developer)
2004-12-09 18:19

OK, I figured out what's going on and it's not aMule's fault.

Most of the time I run aMule via a cron job to keep it on a schedule. I only run it on the weekend and I use two cron jobs: one to start it on Friday evening and another to quit it on Monday morning. This works quite well with some minor limitations.

However, Mac OS X seems to treat GUI programs started via a cron job slightly differently than those started by launching the app from the Finder or from the Terminal. Apparently, a process's parentage (whether it's a descendant of the WindowServer process) matters. Anyway, for some reason, when aMule is launched via cron job it doesn't properly connect to the Clipboard/Pasteboard services of the OS. Therefore the Edit menu problems with the text fields. I have reproduced these problems in TextEdit when launching via cron.

It seems that, when run from the Finder or from Terminal, aMule has functional Edit commands in text fields. So, all this is my fault. Sorry.
(0000441)
Kry (manager)
2004-12-09 18:28

After killing ken painfully, closed 'pseudo-bug'

- Issue History
Date Modified Username Field Change
2004-11-04 23:04 ken New Issue
2004-11-13 13:58 Kry Status new => assigned
2004-11-13 13:58 Kry Assigned To => Kry
2004-11-19 05:30 Kry Relationship added related to 0000187
2004-11-19 05:31 Kry Note Added: 0000389
2004-11-21 11:00 ken Note Added: 0000404
2004-11-21 20:28 Kry Status assigned => resolved
2004-11-21 20:28 Kry Resolution open => fixed
2004-11-21 20:28 Kry Note Added: 0000408
2004-12-05 04:56 ken Status resolved => feedback
2004-12-05 04:56 ken Resolution fixed => reopened
2004-12-05 04:56 ken Note Added: 0000419
2004-12-08 21:27 Kry Summary No Edit menu or Cut, Copy, Paste functionality => [Mac] No Edit menu or Cut, Copy, Paste functionality
2004-12-09 18:19 ken Note Added: 0000440
2004-12-09 18:28 Kry Status feedback => closed
2004-12-09 18:28 Kry Note Added: 0000441


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker