View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000238aMuleSearchpublic2004-12-23 15:392004-12-24 20:53
Reporterpoulpe 
Assigned ToGonoszTopi 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.0.0-rc8 
Target VersionFixed in Version 
Summary0000238: amuleweb search produces cryptic characters
DescriptionWhen doing a search in the web interface of aMule, I obtain results filled with weird characters and question marks.
It smells like an unicode problem...
I'm using the Mandrake 10.1 RPMs packages from your site (I was previously running aMule RC7 - ansi RPMs - without any problem).
TagsNo tags attached.
Fixed in Revision
Operating System
Attached Filesjpg file icon bug238.jpg [^] (129,135 bytes) 2004-12-23 17:21


patch file icon searchfix.patch [^] (883 bytes) 2004-12-24 15:59 [Show Content]

- Relationships

-  Notes
(0000463)
poulpe (reporter)
2004-12-23 17:23

You can see in attached screenshot the result of a search with the keyword 'knoppix'...
(0000467)
poulpe (reporter)
2004-12-24 13:04

I updated the aMule package to 5mdk but the issue is still present...
Did you reproduce the problem ?
(0000468)
GonoszTopi (administrator)
2004-12-24 14:19

I had the same problem myself.
It got fixed, but probably the 5mdk packages were released before the fix.

Try to contact the Mandrake packager whether he wants to make a new package.
(0000469)
poulpe (reporter)
2004-12-24 15:12

Thanks, I'll try that. Or I will compile it myself from CVS.
(0000470)
GonoszTopi (administrator)
2004-12-24 15:58
edited on: 2004-12-24 16:00

I don't know which CVS version the fix went (or will go) into.
Therefore I post you the patch here. Apply with "patch -p0 < searchfix.patch" from your aMule source tree root.

Please report if it's ok for you too, so I can close this bug finally.

edited on: 12-24-04 16:00
(0000472)
poulpe (reporter)
2004-12-24 18:51

I applied the patch... And it works perfectly now!

You can close the bug.

Many thanks and happy Xmas!
(0000473)
GonoszTopi (administrator)
2004-12-24 20:53

Merry Christmas and have a nice aMule experience!

- Issue History
Date Modified Username Field Change
2004-12-23 15:39 poulpe New Issue
2004-12-23 17:21 poulpe File Added: bug238.jpg
2004-12-23 17:23 poulpe Note Added: 0000463
2004-12-24 01:49 GonoszTopi Status new => assigned
2004-12-24 01:49 GonoszTopi Assigned To => GonoszTopi
2004-12-24 05:16 GonoszTopi Status assigned => resolved
2004-12-24 05:16 GonoszTopi Resolution open => fixed
2004-12-24 13:04 poulpe Status resolved => feedback
2004-12-24 13:04 poulpe Resolution fixed => reopened
2004-12-24 13:04 poulpe Note Added: 0000467
2004-12-24 14:19 GonoszTopi Note Added: 0000468
2004-12-24 15:12 poulpe Note Added: 0000469
2004-12-24 15:58 GonoszTopi Note Added: 0000470
2004-12-24 15:59 GonoszTopi File Added: searchfix.patch
2004-12-24 16:00 GonoszTopi Note Edited: 0000470
2004-12-24 18:51 poulpe Note Added: 0000472
2004-12-24 20:53 GonoszTopi Status feedback => resolved
2004-12-24 20:53 GonoszTopi Resolution reopened => fixed
2004-12-24 20:53 GonoszTopi Note Added: 0000473


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker