View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001497aMulePreferencespublic2009-02-25 14:192011-04-17 14:48
Assigned To 
StatusresolvedResolutionno change required 
PlatformOSOS Version
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001497: ipfilter failed to load

Each time I start aMule, I get the error in the aMule log:
"Échec du chargement de fichier ipfilter.dat '/Users/pre/Library/Application Support/aMule/ipfilter.dat', format inconnu."
That mean: failed to load ipfilter.dat, because the file is in an unknow format.
I tried lot of different ipfilter.dat and I get each time the same error.
I have tried to use .dat and .zip format in the URL to load the file, but I get the same error.
I'm using aMule 2.2.3 on Mac OS X 10.5.6 French.
Could you check if the ipfilter feature works well ?

TagsNo tags attached.
Fixed in Revision
Operating SystemMac OS X 10.5.6 FR
Attached Files

- Relationships

-  Notes
sturedman (developer)
2009-02-28 00:03

Try removing the comments frome the filter file, especially the >> characters.
PRe (reporter)
2009-04-06 01:19


I apologize for delay in answering.
I have followed your advice, and that successfuly fix the problem.

Maybe you should consider review ipfilter parsing in amule, in order to avoid the need of manual removing of comments line.

Many thanks for help.
Marcell (developer)
2009-05-12 17:47

Which file contains the ">>" characters?

I had a look into ipfilter.dat and ipfilter_static.dat and there is no such thing.

- Issue History
Date Modified Username Field Change
2009-02-25 14:19 PRe New Issue
2009-02-25 14:19 PRe Operating System => Mac OS X 10.5.6 FR
2009-02-28 00:03 sturedman Note Added: 0003086
2009-04-06 01:19 PRe Note Added: 0003111
2009-05-12 17:47 Marcell Note Added: 0003132
2011-04-17 14:48 GonoszTopi Status new => resolved
2011-04-17 14:48 GonoszTopi Resolution open => no change required

Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker